Getting GfxInfo driver date seems to fail if date has 8 digits

RESOLVED FIXED

Status

()

Core
Graphics
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: JK, Assigned: bjacob)

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8) Gecko/20100101 Firefox/4.0b8
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b9pre) Gecko/20101224 Firefox/4.0b9pre

No graphics driver date in about:support, at least with newer ATI/AMD drivers (10.11+). I think it works with older drivers.

Adapter Description ATI Radeon HD 4600 Series

Vendor ID 1002

Device ID 9498

Adapter RAM 1024

Adapter Drivers aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
Driver Version 8.801.0.0

Driver Date

Direct2D Enabled true

DirectWrite Enabled true

WebGL Renderer TransGaming Inc. -- ANGLE -- OpenGL ES 2.0 (git-devel Dec 24 2010 03:43:25)

GPU Accelerated Windows 1/1 Direct3D 10

Reproducible: Always
(Reporter)

Updated

7 years ago
blocking2.0: --- → ?
Version: unspecified → Trunk
(Reporter)

Comment 1

7 years ago
Catalyst 10.12 is the version I have currently.

Comment 2

7 years ago
I can confirm, Catalyst 10.12 with ATI Radeon 5800 series, other information is there but no date.
Same here with Catalyst 10.12 on a Radeon HD 5770.

It was also missing with whatever I had installed prior to updating to 10.12 tonight. (I think I was on 10.10, but don't remember for sure.)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Looks like I found out a reason of this issue.
Apparently Firefox looks in registry HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E968-E325-11CE-BFC1-08002BE10318}\0000 for "DriverDate" key. It looks like:
"DriverDate"="11-25-2010"

The problem is length of this key. If I change this key to something like:

"DriverDate"="9-25-2010" or
"DriverDate"="11-2-2010" or
"DriverDate"="11-25-201"

driver date in about:support is shown.
Looks like Firefox can not show driver date that consists from 8 digits.

Updated

7 years ago
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
That key's for me is "5-14-2009", and I'm not seeing Driver date in about support, so this sounds right. 

That exact key's for an old, uninstalled Nvidia video card for me, though. My current ATI card's DriverDate key's value is "11-25-2010": 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E968-E325-11CE-BFC1-08002BE10318}\0000

So, this?
http://mxr.mozilla.org/mozilla-central/source/widget/src/windows/GfxInfo.cpp#238
Assignee: nobody → bjacob
blocking2.0: ? → -
Summary: No graphics driver date in about:support → Getting GfxInfo driver date seems to fail if date has 8 digits
(Assignee)

Comment 6

7 years ago
Created attachment 502784 [details] [diff] [review]
fix calls to RegQueryValueExW

RegQueryValueExW's last parameter is in-out and needs to be set to the appropriate value before every call. That might or might not be the reason for this bug.
Attachment #502784 - Flags: review?
(Assignee)

Updated

7 years ago
Attachment #502784 - Flags: review? → review?(jmuizelaar)
Attachment #502784 - Flags: review?(jmuizelaar) → review+
(Reporter)

Updated

7 years ago
Keywords: checkin-needed
needs approval
Keywords: checkin-needed

Updated

7 years ago
Blocks: 594464
Attachment #502784 - Flags: approval2.0+
(Assignee)

Comment 8

7 years ago
Someone landed this already.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.