Can't see a mail attachement (only one case)

RESOLVED DUPLICATE of bug 674473

Status

defect
RESOLVED DUPLICATE of bug 674473
8 years ago
8 years ago

People

(Reporter: stephane.gregoire, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b9pre) Gecko/20101227 Firefox/4.0b9pre SeaMonkey/2.1b2pre
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b9pre) Gecko/20101227 Firefox/4.0b9pre SeaMonkey/2.1b2pre

Hi,

A friend of mine send me a pps file and with latest builds I can't open it.

With Seamonkey 2.0.11 it works.

I will try with other nightly build and say which ones work!

Reproducible: Always

Steps to Reproduce:
1.Someone send you with Microsoft Exchange V6.5 a pps file.
 
Actual Results:  
blank mail

Expected Results:  
See the attachment.

mail header (I changed sensible content).
I will attach the mail later.

From - Thu Dec 23 18:57:26 2010
X-Account-Key: account4
X-UIDL: 8540.6docAtIrncVEf0GiyoFpSHz+mcU=
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
X-Mozilla-Keys:                                                                                 
Return-Path: nobody@credit-cgi.fr.nospam
Received: from zimbra41-e7.priv.proxad.net (LHLO
 zimbra41-e7.priv.proxad.net) (172.20.243.191) by
 zimbra41-e7.priv.proxad.net with LMTP; Wed, 22 Dec 2010 13:48:23 +0100
 (CET)
Received: from relay4-v.mail.gandi.net (mx23-g26.priv.proxad.net [172.20.243.93])
	by zimbra41-e7.priv.proxad.net (Postfix) with ESMTP id 10A2AEE0B
	for <nobody@free-fr.nospam>; Wed, 22 Dec 2010 13:48:23 +0100 (CET)
Received: from relay4-v.mail.gandi.net ([217.70.178.78])
	by mx1-g20.free-fr.nospam (MXproxy) for nobody@free-fr.nospam ;
	Wed, 22 Dec 2010 13:48:23 +0100 (CET)
X-ProXaD-SC: state=HAM score=0
X-Originating-IP: 10.0.21.72
Received: from spool.mail.gandi.net (mspool2-v.mgt.gandi.net [10.0.21.72])
	by relay4-v.mail.gandi.net (Postfix) with ESMTP id CE56CBA2C
	for <nobody@free-fr.nospam>; Wed, 22 Dec 2010 13:48:22 +0100 (CET)
Received: from mfilter8-d.gandi.net (mfilter8-d.gandi.net [217.70.178.34])
	by spool.mail.gandi.net (Postfix) with ESMTP id 9553E32C061
	for <nobody@free-fr.nospam>; Wed, 22 Dec 2010 13:48:22 +0100 (CET)
X-Virus-Scanned: Debian amavisd-new at mfilter8-d.mgt.gandi.net
Received: from spool.mail.gandi.net ([10.0.21.72])
	by mfilter8-d.gandi.net (mfilter8-d.gandi.net [217.70.178.34]) (amavisd-new, port 10024)
	with ESMTP id xS5iMkBqRQXK for <nobody@free-fr.nospam>;
	Wed, 22 Dec 2010 13:48:22 +0100 (CET)
Received: from relay01.credit-cgi.fr.nospam (relay01.credit-cgi.fr.nospam [195.115.154.146])
	by spool.mail.gandi.net (Postfix) with ESMTP id 6B65232C06D
	for <nobody@beurdin.org>; Wed, 22 Dec 2010 13:48:16 +0100 (CET)
Received: by relay01.credit-cgi.fr.nospam (Postfix, from userid 500)
	id A92301C2AD2; Wed, 22 Dec 2010 13:48:15 +0100 (CET)
Received: from MCQ-MES50.cgi.credit-cgi.fr.nospam (unknown [192.168.8.1])
	by relay01.credit-cgi.fr.nospam (Postfix) with ESMTP id ECC371C2AC4;
	Wed, 22 Dec 2010 13:48:14 +0100 (CET)
Content-class: urn:content-classes:message
MIME-Version: 1.0
Content-Type: multipart/related;
	boundary="----_=_NextPart_001_01CBA1D6.7D366574";
	type="multipart/alternative"
X-MimeOLE: Produced By Microsoft Exchange V6.5
Subject: =?iso-8859-1?Q?TR=3A_Tr_=3A_=E0_vos_pelles_=21_=21?=
Date: Wed, 22 Dec 2010 13:48:09 +0100
Message-ID: <B814E02AB390E547A3ED6467769E1C6A07C42D4C@MCQ-MES50.cgi.credit-cgi.fr.nospam>
X-MS-Has-Attach: yes
X-MS-TNEF-Correlator: 
Thread-Topic: =?iso-8859-1?Q?Tr_=3A_=E0_vos_pelles_=21_=21?=
thread-index: AcugSlmvgGwVX7WTT2aY2BmWmjMCGQAASOHwAGK3C4A=
From: "nobody nobody" <nobody@credit-cgi.fr.nospam>
To: undisclosed-recipients:;
X-Disclaimer: credit-cgi.fr.nospam

This is a multi-part message in MIME format.

------_=_NextPart_001_01CBA1D6.7D366574
Content-Type: multipart/alternative;
	boundary="----_=_NextPart_002_01CBA1D6.7D366574"


------_=_NextPart_002_01CBA1D6.7D366574
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

=20
=20


=20
=20
=20
=20
=20
=20
=20
<http://www.incredimail.com/app/?tag=3Demoticon_click_me_im2_re&lang=3D12=
&version=3D6224754&setup_id=3D12000007&aff_id=3D1&addon=3DIncrediMail&upn=
=3DBB490B8E-B2D3-4D2C-A4DC-44DABF84DAF3&id=3D95202&guid=3DE3C305A5-485D-4=
42B-BC87-143C1F603D87>=20
=20

=09
=09

<http://www.incredimail.com/?id=3D613059&rui=3D126700021&sd=3D20101218>=20

*************************************************************************=
=0ACe message et toutes les pi=E8ces jointes (ci-apr=E8s le "message") sont=
=0Aconfidentiels et =E9tablis =E0 l'intention exclusive de ses destinataires=
.=0AToute utilisation ou diffusion non autoris=E9e est interdite.=0ATout mes=
sage =E9lectronique est susceptible d'alt=E9ration.=0ALa SOCIETE GENERALE et=
 ses filiales d=E9clinent toute responsabilit=E9 au titre=0Ade ce message s'=
il a =E9t=E9 alt=E9r=E9, d=E9form=E9 ou falsifi=E9.=0A********=0AThis messag=
e and any attachments (the "message") are confidential and=0Aintended solely=
 for the addressees.=0AAny unauthorised use or dissemination is prohibited.=
=0AE-mails are susceptible to alteration.=0ANeither SOCIETE GENERALE nor any=
 of its subsidiaries or affiliates shall be=0Aliable for the message if alte=
red, changed or falsified.=0A=0A

------_=_NextPart_002_01CBA1D6.7D366574
Content-Type: text/html;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=3DContent-Type content=3D"text/html; =
charset=3Diso-8859-1">
<STYLE>.hmmessage P {
	PADDING-RIGHT: 0px; PADDING-LEFT: 0px; PADDING-BOTTOM: 0px; MARGIN: =
0px; PADDING-TOP: 0px
}
BODY.hmmessage {
	FONT-SIZE: 10pt; FONT-FAMILY: Tahoma
}
</STYLE>

<META content=3D"MSHTML 6.00.6000.17093" name=3DGENERATOR></HEAD>
<BODY class=3Dhmmessage>
<DIV dir=3Dltr align=3Dleft>&nbsp;</DIV>
<DIV></DIV>

<DIV dir=3Dltr align=3Dleft><FONT face=3DArial =
color=3D#0000ff></FONT>&nbsp;</DIV><FONT=20
face=3DArial color=3D#0000ff></FONT><BR>
<META content=3D"Microsoft SafeHTML" name=3DGenerator>
<STYLE></STYLE>

<TABLE id=3DecxINCREDIMAINTABLE cellSpacing=3D0 cellPadding=3D2 =
width=3D"100%"=20
  border=3D0><TBODY>
  <TR>
    <TD id=3DecxINCREDITEXTREGION style=3D"FONT-SIZE: 12pt; DIRECTION: =
ltr"=20
    width=3D"100%">
      <DIV id=3DecxINCREDI_TEXT_AREA style=3D"PADDING-LEFT: 2px">
      <DIV>
      <DIV>&nbsp;</DIV>
      <DIV>&nbsp;</DIV>
      <DIV>&nbsp;</DIV></DIV></DIV>
      <DIV>
      <DIV>&nbsp;</DIV>
      <DIV id=3DecxIncrediOriginalFontSize dir=3Dltr=20
      style=3D"FONT-SIZE: 12pt; FONT-FAMILY: Arial">
      <DIV id=3DecxINCREDI_TEXT_AREA style=3D"PADDING-LEFT: 2px">
      <DIV><STRONG><FONT size=3D5></FONT></STRONG>&nbsp;</DIV>
      <DIV><STRONG><FONT size=3D5></FONT></STRONG>&nbsp;</DIV>
      <DIV><STRONG><FONT size=3D5></FONT></STRONG>&nbsp;</DIV>
      <DIV align=3Dcenter><A title=3DCliquez-moi!=20
      =
href=3D"http://www.incredimail.com/app/?tag=3Demoticon_click_me_im2_re&am=
p;lang=3D12&amp;version=3D6224754&amp;setup_id=3D12000007&amp;aff_id=3D1&=
amp;addon=3DIncrediMail&amp;upn=3DBB490B8E-B2D3-4D2C-A4DC-44DABF84DAF3&am=
p;id=3D95202&amp;guid=3DE3C305A5-485D-442B-BC87-143C1F603D87"=20
      target=3D_blank></A></DIV></DIV>
      <DIV><FONT color=3D#0000ff =
size=3D2></FONT>&nbsp;</DIV></DIV></DIV></TD></TR>
  <TR>
    <TD id=3DecxINCREDIFOOTER width=3D"100%">
      <TABLE cellSpacing=3D0 cellPadding=3D0 width=3D"100%">
        <TBODY>
        <TR>
          <TD width=3D"100%"><BR></TD>
          <TD id=3DecxINCREDISOUND vAlign=3Dbottom=20
      =
align=3Dmiddle><BR></TD></TR></TBODY></TABLE></TD></TR></TBODY></TABLE><S=
PAN=20
id=3DecxIncrediStamp><A=20
href=3D"http://www.incredimail.com/?id=3D613059&amp;rui=3D126700021&amp;s=
d=3D20101218"=20
target=3D_blank><SPAN></SPAN></A></SPAN>

<br>=
************************************************************************* <=
br/>=0ACe message et toutes les pi&#232;ces jointes (ci-apr&#232;s le "messa=
ge") sont<br/>=0Aconfidentiels et &#233;tablis &#224; l'intention exclusive =
de ses destinataires.<br/>=0AToute utilisation ou diffusion non autoris&#233=
;e est interdite.<br/>=0ATout message &#233;lectronique est susceptible d'al=
t&#233;ration.<br/>=0ALa SOCIETE GENERALE et ses filiales d&#233;clinent tou=
te responsabilit&#233; au titre<br/>=0Ade ce message s'il a &#233;t&#233; al=
t&#233;r&#233;, d&#233;form&#233; ou falsifi&#233;.<br/>=0A********<br/>=0AT=
his message and any attachments (the "message") are confidential and<br/>=0A=
intended solely for the addressees.<br/> =0AAny unauthorised use or dissemin=
ation is prohibited.<br/>=0AE-mails are susceptible to alteration.<br/>=0ANe=
ither SOCIETE GENERALE nor any of its subsidiaries or affiliates shall be<br=
/>=0Aliable for the message if altered, changed or falsified.<br/>=0A

<br>=
</BODY></HTML>

------_=_NextPart_002_01CBA1D6.7D366574--

------_=_NextPart_001_01CBA1D6.7D366574
Content-Type: application/vnd.ms-powerpoint;
	name="la_neige_au_dakota.pps"
Content-Transfer-Encoding: base64
Content-Description: la_neige_au_dakota.pps
Content-Disposition: attachment;
	filename="la_neige_au_dakota.pps"
Content-Location: 1_multipart%3F4_la_neige_au_dakota.pps
(Reporter)

Comment 1

8 years ago
This mail is not shown correctly in Mozilla/5.0 (X11; Linux i686; rv:2.0b9pre) Gecko/20101227 Firefox/4.0b9pre SeaMonkey/2.1b2pre
(Reporter)

Updated

8 years ago
Version: unspecified → Trunk
(Reporter)

Comment 2

8 years ago
I'm using the french locale.

With Seamonkey 2.1b1 build2 I've also the bug.
The message uses a MIME type of multipart/related. This would possibly be correct for an HTML message with embedded content, however it is incorrect for a normal attachment which should be multipart/mixed.
Duping to bug 674473
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 674473
You need to log in before you can comment on or make changes to this bug.