Closed Bug 621718 Opened 9 years ago Closed 8 years ago

Google Bodybrowser is not displayed correctly with OpenGL renderer

Categories

(Core :: Canvas: WebGL, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
blocking2.0 --- -

People

(Reporter: chrizz-tc, Assigned: blizzard)

References

()

Details

(Whiteboard: [input])

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8) Gecko/20100101 Firefox/4.0b8
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8) Gecko/20100101 Firefox/4.0b8

If I want to use the google bodybrowser, I cant see anything else than the labels. Google recommendes the Firefox 4 for using this service, so Ive downloaded and installed the Firefox 4 beta 8. is this a problem in Firefox or a problem with google?

Reproducible: Always

Steps to Reproduce:
1. Type in the adressbar http://bodybrowser.googlelabs.com/body.html# without "/body.html". This will be added automatically.
2. You could not see anything else than the labels, but not the bodyparts.

by the way, I miss the Feedback-button in my betaversion of firefox4, thats why I write here.
Please post you Graphics Information you can get via about:support resp. "Help"/"Troubleshooting Information".

If you want to, you can test against Nightly Build (http://nightly.mozilla.org/).
A lot of people on input are complaining about this issue for beta 8:

http://input.mozilla.com/en-US/sites/theme/29222
Status: UNCONFIRMED → NEW
Component: General → Canvas: WebGL
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → canvas.webgl
Whiteboard: [input]
Is this a win32 specific bug?

I'm using FF4.0b8 on osx10.6.5 and have been using google bodybrowser for a few days now without any problems.
It works fine for me without any problems.
Mozilla/5.0 (Windows NT 6.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
This is not a Firefox bug, but a bug in graphics drivers, as far as we can see. That's why it works fine for certain people and not for others.

If you're running Windows and it doesn't work for you, install the DirectX runtime (no, it's not the DirectX stuff you already have):
http://www.microsoft.com/downloads/en/details.aspx?FamilyID=2da43d38-db71-4c1b-bc6a-9b6652cd92a3&displaylang=en

That allows Firefox to use Direct3D instead of OpenGL for rendering, working around certain poor OpenGL drivers on Windows. We're working on doing this automatically in FF4 final.
Doing some outreach to try and find the right person.
Assignee: nobody → blizzard
Status: NEW → ASSIGNED
Seems to work fine wherever I've tested it.

Note that b8 has some issues, mostly affecting Intel hardware, but potentially some others as well:
- using ANGLE requires that the user already have the dx9 redist installed, since we don't yet ship it
- if the dx9 redist isn't available, using ANGLE will fail, and we'll automatically try the OpenGL driver; this will succeed even when it shouldn't (e.g. Intel)
- WebGL doesn't validate the OpenGL implementation sufficiently and can result in broken rendering when it assumes some things are available
I pinged the google people a little while ago; nothing back yet.
(In reply to comment #10)
> User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8) Gecko/20100101
> Firefox/4.0b8
> Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8) Gecko/20100101
> Firefox/4.0b8

Maybe this is specific to 64bit windows? It looks like its working for win32, and for OSX.



(In reply to comment #3)
> Is this a win32 specific bug?
> 
> I'm using FF4.0b8 on osx10.6.5 and have been using google bodybrowser for a few
> days now without any problems.

Additional info: I'm now running FF4.0b9 on osx10.6.6 and can use google bodybrowser without problems.
blocking2.0: --- → ?
Version: unspecified → Trunk
We need to use ANGLE for rendering WebGL, but bodybrowser in particular doesn't need to block.
blocking2.0: ? → -
Summary: Google Bodybrowser is not displayed correctly → Google Bodybrowser is not displayed correctly with OpenGL renderer
Please reopen if this still doesn't work for you. If it doesn't work, we probably just need to blacklist the driver, and you should try updating your drivers.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.