The default bug view has changed. See this FAQ.

--as-needed breakage when compiling spidermonkey from trunk

RESOLVED FIXED in mozilla2.0

Status

()

Core
Build Config
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Jory A. Pratt, Unassigned)

Tracking

unspecified
mozilla2.0
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-in-tracemonkey)

Attachments

(1 attachment, 1 obsolete attachment)

756 bytes, patch
khuey
: review+
Details | Diff | Splinter Review
(Reporter)

Description

6 years ago
Created attachment 500134 [details]
patch v1

Spidermonkey will fail with undefined references if --as-needed is passed via LDFLAGS from the enviroment. Simply reorder the libs to resolve issue.
(Reporter)

Comment 1

6 years ago
Created attachment 500135 [details] [diff] [review]
patch v1
Attachment #500134 - Attachment is obsolete: true
Attachment #500135 - Flags: review?(khuey)
Attachment #500135 - Flags: review?(khuey) → review+
(Reporter)

Updated

6 years ago
Keywords: checkin-needed
http://hg.mozilla.org/tracemonkey/rev/34d34da6c764
Keywords: checkin-needed
Whiteboard: fixed-in-tracemonkey
Duplicate of this bug: 547715
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0
You need to log in before you can comment on or make changes to this bug.