Cookie with quoted path is not stored

RESOLVED DUPLICATE of bug 610218

Status

()

RESOLVED DUPLICATE of bug 610218
8 years ago
8 years ago

People

(Reporter: jakub, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b8) Gecko/20100101 Firefox/4.0b8
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8) Gecko/20100101 Firefox/4.0b8

According to RFC 2109, it is possible to surround cookie path by quotes. Firefox 4 beta 8 however did not store such cookies. In Firefox 3, this worked.

Reproducible: Always

Steps to Reproduce:
document.cookie = 'test=1; path="/test/cookie.php"';
alert(document.cookie);

Actual Results:  
''

Expected Results:  
'test=1'
Hmm, on Mozilla/5.0 (Windows NT 5.1; rv:2.0b9pre) Gecko/20101229 Firefox/4.0b9pre ID:20101229030346 the Cookie Manager tells me

Name: test
Content: 1
Host: www.vrana.cz
Path: /test/cookie.php

Comment 2

8 years ago
I also see the cookie being set if I go to cookie manager in Mozilla/5.0 (Windows NT 5.1; rv:2.0b9pre) Gecko/20101229 Firefox/4.0b9pre ID:20101229030346

However, the alert(document.cookie); is showing up blank. Jakub -> is that the issue you are seeing?
(Reporter)

Comment 3

8 years ago
The cookie in testing script is set by JavaScript. However the same behavior appears when the cookie is sent from the server.

Updated

8 years ago
Version: unspecified → Trunk

Comment 4

8 years ago
DUPLICATE of bug 610218 ?

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 610218
You need to log in before you can comment on or make changes to this bug.