Bing map doesn't load on realtor.ca (caused by bug 591981)

RESOLVED FIXED

Status

RESOLVED FIXED
8 years ago
4 days ago

People

(Reporter: tnikkel, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
Load http://www.realtor.ca/map.aspx the map doesn't display. (It seems to work if the page is in your cache though.)

Regression range is the push containing bug 591981, and I doubt its the spacer bug.
blocking2.0: --- → ?
Looks like the page works if I use Safari's UA string. Observing that the map is provided by Microsoft's Bing Maps.

Raul, Any chance of Bing Maps using the same script loader as Live Calendar and Hotmail? That is, should we expect Bing Maps to get fixed whenever the Live Calendar / Hotmail fix (bug 610917 and bug 609236) is deployed?
Assignee: nobody → english-us
Component: DOM → English US
Product: Core → Tech Evangelism
QA Contact: general → english-us
Summary: map doesn't load on realtor.ca (caused by bug 591981) → Bing map doesn't load on realtor.ca (caused by bug 591981)
Version: Trunk → unspecified

Comment 2

8 years ago
@Henri,

Not sure Bing is using the exact same code though likely the same issue or workaround. I'll investigate and get the Bing devs involved. Thanks for the heads up.
The Bing Maps team has been contacted. Thanks Raul.
Assignee: english-us → hsivonen

Updated

8 years ago
Assignee: hsivonen → nobody
Component: English US → General
Product: Tech Evangelism → Core
QA Contact: english-us → general

Updated

8 years ago
blocking2.0: ? → ---

Updated

8 years ago
Assignee: nobody → english-us
Component: General → English US
Product: Core → Tech Evangelism
QA Contact: general → english-us
(Reporter)

Comment 4

8 years ago
Any updates here? Map still doesn't load for me.
Microsoft is looking into it.

Comment 6

8 years ago
This looks fixed to me? realtor.ca is working for me in 4.0RC.
(Reporter)

Comment 7

8 years ago
Still doesn't work for me in latest nightly. Cache might have an effect, so clear the cache before testing.

Comment 8

8 years ago
This is strange. Latest nightly and 4.0RC on different systems are both broken...

(so why did it work on the first system I tried with 4.0RC?)
(Reporter)

Comment 9

8 years ago
Since cache seems to play a factor its probably a timing issue.

Comment 10

8 years ago
tn, can you try again now? I just tried 4.0 final on 4 systems, works fine on all of them...
(Reporter)

Comment 11

8 years ago
It still doesn't work consistently for me. Sometimes it works, but a lot of the time it doesn't. I tried in a fresh profile. Clearing the cache and restarting seems to be a good way to reproduce for me. I tested using the latest nightly (not 4.0 final).
Working for me on Firefox 32.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Component: English US → Desktop
Resolution: --- → FIXED
Component: Desktop → Desktop
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.