Crash [@ linux-gate.so@0x430 ] X_FreeGC: BadGC (invalid GC parameter); 3 requests ago

VERIFIED DUPLICATE of bug 621699

Status

()

VERIFIED DUPLICATE of bug 621699
8 years ago
8 years ago

People

(Reporter: kbrosnan, Unassigned)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

8 years ago
Talked with a user, wucan, on IRC he crashes any time he opens a support.mozilla.org page on Ubuntu 10.10 using Firefox 4 b8. His crash is http://crash-stats.mozilla.com/report/index/9a1beda9-ddb9-4f62-96e0-2b8322101229

Have a email address for the user, if needed.

Comment 1

8 years ago
linux-gate.so here just means "syscall asking to abort()", it's uninteresting.

Signature	linux-gate.so@0x430
UUID	9a1beda9-ddb9-4f62-96e0-2b8322101229
Time	2010-12-29 01:58:33.4495
Uptime	136
Last Crash	139 seconds before submission
Install Age	90964 seconds (1.1 days) since version was first installed.
Product	Firefox
Version	4.0b8
Build ID	20101214164501
Branch	2.0
OS	Linux
OS Version	0.0.0 Linux 2.6.37-rc7+ #8 SMP Wed Dec 22 16:55:22 CST 2010 i686
CPU	x86
CPU Info	GenuineIntel family 6 model 23 stepping 10
Crash Reason	SIGABRT
Crash Address	0x2379
User Comments	crashed when visit: http://support.mozilla.com/bs/questions/701756
App Notes	X_FreeGC: BadGC (invalid GC parameter); 3 requests ago
Processor Notes	
EMCheckCompatibility	False
Related Bugs

Frame	Module	Signature [Expand]	Source
0	linux-gate.so	linux-gate.so@0x430	
1	libc-2.12.1.so	libc-2.12.1.so@0x2de41	
2	libmozalloc.so	mozalloc_abort	 mozalloc_abort.cpp:75
3	libxul.so	NS_DebugBreak_P	xpcom/base/nsDebugImpl.cpp:379
4	libxul.so	X11Error	toolkit/xre/nsX11ErrorHandler.cpp:190
5	libbonoboui-2.so.0.0.0	libbonoboui-2.so.0.0.0@0x20c73	
6	libX11.so.6.3.0	libX11.so.6.3.0@0x3b2c8	
7	libX11.so.6.3.0	libX11.so.6.3.0@0x4199e	
8	libX11.so.6.3.0	libX11.so.6.3.0@0x42405	
9	libX11.so.6.3.0	libX11.so.6.3.0@0x2aa97	
10	libgdk-x11-2.0.so.0.2200.0	libgdk-x11-2.0.so.0.2200.0@0x538d7	
11	libglib-2.0.so.0.2600.0	libglib-2.0.so.0.2600.0@0x40e69	
12	libglib-2.0.so.0.2600.0	libglib-2.0.so.0.2600.0@0x41278	
13	libglib-2.0.so.0.2600.0	libglib-2.0.so.0.2600.0@0x41847	
14	libxul.so	nsAppShell::ProcessNextNativeEvent	widget/src/gtk2/nsAppShell.cpp:144
15	libxul.so	nsBaseAppShell::DoProcessNextNativeEvent	widget/src/xpwidgets/nsBaseAppShell.cpp:173
16	libxul.so	nsBaseAppShell::OnProcessNextEvent	widget/src/xpwidgets/nsBaseAppShell.cpp:315
17	libxul.so	nsThread::ProcessNextEvent	xpcom/threads/nsThread.cpp:590
18	libxul.so	NS_ProcessNextEvent_P	 nsThreadUtils.cpp:250
19	libxul.so	mozilla::ipc::MessagePump::Run	ipc/glue/MessagePump.cpp:110
20	libxul.so	MessageLoop::RunInternal	ipc/chromium/src/base/message_loop.cc:219
21	libxul.so	MessageLoop::Run	ipc/chromium/src/base/message_loop.cc:202
22	libxul.so	nsBaseAppShell::Run	widget/src/xpwidgets/nsBaseAppShell.cpp:192
23	libxul.so	nsAppStartup::Run	toolkit/components/startup/src/nsAppStartup.cpp:191
24		@0xb77aa777	
25	libxul.so	XRE_main	toolkit/xre/nsAppRunner.cpp:3691
26	firefox-bin	main	 nsBrowserApp.cpp:158
27	libc-2.12.1.so	libc-2.12.1.so@0x16ce6	
28	firefox-bin	firefox-bin@0x1390	
29	firefox-bin	Output	 nsBrowserApp.cpp:77
30		@0x0	

user needs to run with --sync, and preferably with bonoboui not loading. An x11 protocol trace may eventually be useful, but let's just try --sync
Component: General → Graphics
Keywords: crashreportid → stackwanted
Product: Firefox → Core
QA Contact: general → thebes
Summary: Crash [@ linux-gate.so@0x430 ] → Crash [@ linux-gate.so@0x430 ] X_FreeGC: BadGC (invalid GC parameter); 3 requests ago

Comment 2

8 years ago
i'm going to dupe this, please talk him through verifying that he's using webgl
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 621699
(Reporter)

Comment 3

8 years ago
To the best of my knowledge there are not any webgl demos on support.mozilla.com.

Comment 4

8 years ago
hrm, well, we need a --sync stack either way. and it won't hurt to get about:support #Graphics (and trying to disable hardware accel if it looks like it's enabled)

Comment 5

8 years ago
I had doing a bisect from beta1 -> beta9prv, I find it's the beta7, from which the access to https://support.mozilla.com crashed.
Then I save the page use another browser, and I found it's the stuff in common-mini.js trigger the crash, rename common-mini.js to what-else make the saved page opened with no crash.

Add -sync with no help yet.

Comment 7

8 years ago
My about:support gave:
Graphics
        GPU Accelerated Windows0/2

It's seem hardware accel had disabled already?

Comment 8

8 years ago
wucan: it's --sync not -sync, and it isn't about getting the crash to go away, it's about getting a useful stack trace to the cause of the crash.

Comment 10

8 years ago
Signature	linux-gate.so@0x430
UUID	4a7024b1-1eb1-4645-8493-f5fbe2110102
Time 	2011-01-02 19:04:48.247187
Uptime	17
Last Crash	242463 seconds (2.8 days) before submission
Install Age	338274 seconds (3.9 days) since version was first installed.
Product	Firefox
Version	4.0b7
Build ID	20101104125541
Branch	2.0
OS	Linux
OS Version	0.0.0 Linux 2.6.37-rc7+ #8 SMP Wed Dec 22 16:55:22 CST 2010 i686
CPU	x86
CPU Info	GenuineIntel family 6 model 23 stepping 10
Crash Reason	SIGABRT
Crash Address	0xd3a
User Comments	regenerate use correct --sync, not -sync.
App Notes 	X_FreeGC: BadGC (invalid GC parameter); sync
Processor Notes 	
EMCheckCompatibility	False
Related Bugs

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	linux-gate.so 	linux-gate.so@0x430 	
1 	libc-2.12.1.so 	libc-2.12.1.so@0x2de41 	
2 	libmozalloc.so 	mozalloc_abort 	mozalloc_abort.cpp:75
3 	libxul.so 	NS_DebugBreak_P 	xpcom/base/nsDebugImpl.cpp:379
4 	libxul.so 	X11Error 	toolkit/xre/nsX11ErrorHandler.cpp:190
5 	libbonoboui-2.so.0.0.0 	libbonoboui-2.so.0.0.0@0x20c73 	
6 	libX11.so.6.3.0 	libX11.so.6.3.0@0x3b2c8 	
7 	libX11.so.6.3.0 	libX11.so.6.3.0@0x4199e 	
8 	libX11.so.6.3.0 	libX11.so.6.3.0@0x42035 	
9 	libX11.so.6.3.0 	libX11.so.6.3.0@0x35866 	
10 	libX11.so.6.3.0 	libX11.so.6.3.0@0x359f4 	
11 	libX11.so.6.3.0 	libX11.so.6.3.0@0x1c283 	
12 	libGL.so.1.2 	libGL.so.1.2@0x376c0 	
13 	libGL.so.1.2 	libGL.so.1.2@0x3798b 	
14 	libGL.so.1.2 	libGL.so.1.2@0x37b04 	
15 	libGL.so.1.2 	libGL.so.1.2@0x37213 	
16 	libGL.so.1.2 	libGL.so.1.2@0x156c5 	
17 	libGL.so.1.2 	libGL.so.1.2@0x158a2 	
18 	libxul.so 	mozilla::gl::GLContextGLX::MakeCurrentImpl 	gfx/thebes/GLContextProviderGLX.cpp:264
19 	libxul.so 	mozilla::gl::GLContextGLX::CreateGLContext 	gfx/thebes/GLContext.h:409
20 	libxul.so 	mozilla::gl::CreateOffscreenPixmapContext 	gfx/thebes/GLContextProviderGLX.cpp:624
21 	libxul.so 	mozilla::gl::GLContextProviderGLX::CreateOffscreen 	gfx/thebes/GLContextProviderGLX.cpp:635
22 	libxul.so 	mozilla::WebGLContext::SetDimensions 	content/canvas/src/WebGLContext.cpp:395
23 	libxul.so 	nsHTMLCanvasElement::UpdateContext 	content/html/content/src/nsHTMLCanvasElement.cpp:514
24 	libxul.so 	nsHTMLCanvasElement::GetContext 	content/html/content/src/nsHTMLCanvasElement.cpp:447
25 	libxul.so 	nsIDOMHTMLCanvasElement_GetContext 	dom_quickstubs.cpp:20968
26 	libxul.so 	CallCompiler::generateNativeStub 	js/src/jscntxtinlines.h:684
27 	libxul.so 	js::mjit::ic::NativeCall 	js/src/methodjit/MonoIC.cpp:851
28 		@0xa76e2549 	
29 	libxul.so 	js::mjit::JaegerShot 	js/src/methodjit/MethodJIT.cpp:739
30 	libxul.so 	js::Execute 	js/src/jsinterp.cpp:662
31 	libxul.so 	JS_EvaluateUCScriptForPrincipals 	js/src/jsapi.cpp:4819
32 	libxul.so 	JS_EvaluateUCScriptForPrincipalsVersion 	js/src/jsapi.cpp:4795
33 	libxul.so 	nsJSContext::EvaluateString 	dom/base/nsJSEnvironment.cpp:1731
34 	libxul.so 	nsScriptLoader::EvaluateScript 	content/base/src/nsScriptLoader.cpp:845
35 	libxul.so 	nsScriptLoader::ProcessRequest 	content/base/src/nsScriptLoader.cpp:748
36 	libxul.so 	nsScriptLoader::ProcessPendingRequests 	content/base/src/nsScriptLoader.cpp:888
37 	libxul.so 	nsScriptLoader::OnStreamComplete 	content/base/src/nsScriptLoader.cpp:1109
Status: RESOLVED → VERIFIED

Comment 11

8 years ago
ok, that was moderately helpful. can you try to remove libbonoboui-2.so.0.0.0 ?

I'm not really sure how one would go about doing that, but, it'd be helpful if you could somehow crash (using --sync) without libbonoboui-2.so.0.0.0 being loaded into the process.

Comment 12

8 years ago
crash without libbonoboui-2.so.0.0.0, wish helpful and feel free to contact me if I can help:
http://crash-stats.mozilla.com/report/index/1c732c0e-9ecb-46a3-94e7-17c3b2110103

Comment 13

8 years ago
(In reply to comment #12)
> crash without libbonoboui-2.so.0.0.0, wish helpful and feel free to contact me
> if I can help:
> http://crash-stats.mozilla.com/report/index/1c732c0e-9ecb-46a3-94e7-17c3b2110103

add User Comment:
http://crash-stats.mozilla.com/report/index/bp-b0c980fc-10c6-434c-883b-50f172110103

Comment 14

8 years ago
thanks. i hope that's all we need.
(Assignee)

Updated

8 years ago
Crash Signature: [@ linux-gate.so@0x430 ]
You need to log in before you can comment on or make changes to this bug.