Closed Bug 622087 Opened 12 years ago Closed 12 years ago

The location zoomed in on page is not the correct location that was double tapped.

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: anamaria.moldovan, Assigned: mbrubeck)

References

()

Details

(Keywords: regression)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8) Gecko/20100101 Firefox/4.0b8
Build Identifier: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b9pre) Gecko/201012230Firefox/4.0b9pre Fennec /4.0b4pre

The location zoomed in on page is not the correct location that was double tapped. Also on some websites (eg. http://bugzilla.mozilla.org) the items from the page content are slightly off.

Devices: HTC Desire (Android 2.1), Motorola Droid 2(Android 2.2).

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.mozilla.org
2. Perform a double tap on the screen (left-down corner) to zoom in

Actual Results:  
The location zoomed in is in fact the right up corner (the diagonally opposite corner) (see the attached photo1)

Expected Results:  
Confirm that Location zoomed in on page is the correct location that you double tapped.

Also on http:// bugzilla.mozilla.org when performing a double tap on the screen (left-down corner) to zoom in the item on the page content will be slightly off.
Please see the attached photo2.  
Sometimes, when double tapping the page is heavily zoomed and not centered at all. Please see the following video: http://www.youtube.com/watch?v=8hIs2y2168E
OS: Other → Android
Hardware: Other → ARM
Attached image photo1
Attached image photo2
tracking-fennec: --- → ?
Keywords: regression
This is caused by the landing of our "Easy Reading" feature, I think?
Assignee: nobody → mbrubeck
With the new "Reformat text" option enabled (bug 611555), the expected behavior of double-tap is to find the page element that was tapped, zoom so that element fills the screen, and reformat the text so that it is sized based on the screen width.

On mozilla.org, if you double-tap on specific text in the lower right, we will zoom to that text.  But if you double-tap in certain areas of white space, then you end up zooming to the entire document.  The area shown in the screenshot is not actually the top left corner, but the entire width of the page; the reformatted text makes the page much taller so 

On bugzilla.mozilla.org, tapping in whitespace (or in any element with 100% width) again zooms to the entire page width, and the screenshot shows the results of reformatting text to be visible at that width.
Blocks: 611555
Status: NEW → RESOLVED
Closed: 12 years ago
OS: Android → All
Hardware: ARM → All
Resolution: --- → INVALID
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.