Home Button Automatically moves to the right end of the navigation bar

RESOLVED INVALID

Status

()

Firefox
Toolbars and Customization
RESOLVED INVALID
8 years ago
5 years ago

People

(Reporter: Thirumalaisamy K, Unassigned)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

(Whiteboard: [Input])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8) Gecko/20100101 Firefox/4.0b8
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8) Gecko/20100101 Firefox/4.0b8

I have moved the home button near to the navigation buttons. After some restarts of browser it is once again automatically moved to the right end that is after the search bar.

Reproducible: Always

Comment 1

8 years ago
same problem here, tried to reset toolbar settings but did not work and now i have a rather large empty space under my bookmarks toolbar that wont go away (was fine before toolbar reset) and even if i get rid of the bookmarks toolbar, the useless space doesn't go away

Comment 2

8 years ago
also i cannot right click on the empty space and if i go back to the default theme the empty space moves in between the bookmarks toolbar and the awesomebar

was using liscie 1 theme originally

Comment 3

8 years ago
i just switched back to the theme i was using before and the empty space stayed in between the bookmarks toolbar and the awesomebar

Comment 4

8 years ago
found the problem with the empty space, it is caused by destroy the web addon

note: even after removing it the empty space doesn't go away, u have to use a new profile

found this out after playing around with a new profile

also try creating a new profile, it solved the home button going back to the right side issue for me
Common Issue on Input: http://input.mozilla.com/en-US/search/?product=firefox&version=&date_start=07%2F08%2F2010&date_end=&q=home+button
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86_64 → All
Whiteboard: [Input]
Aakash: the common issue seems to be that people are upset that it moved at all; this bug seems to be about the fact that even after users customize the toolbar and move the button back to the left, it returns to the right after a few restarts. That doesn't seem common from the Input link you showed, here, right?

Reporter: was the entire problem with the Destroy the Web Add-on, or can you still not get your customizations to stick?

Comment 7

8 years ago
Unless the add-on is messing with the pref browser.migration.version, which no add-on should be messing with, or the add-on is corrupting toolbars, this should never happen. I'm 100% confident that it's not a problem with our browser code.
Yeah, this is different. Though there are a number of people complaining about this as well: http://input.mozilla.com/en-US/search/?product=firefox&q=home+button+customize (better search)
Fryn, that's more comments than I would have expected. For now I'll customize my home button and see if I can get it to happen to me, but if someone could help us get to reliable STR here, that would be great.

Comment 10

8 years ago
Also, any toolbar changes won't be saved if Firefox crashes or doesn't quit properly. That doesn't explain this bug though, since once Firefox has successfully saved the new toolbar states, they should not revert. Then again, we do store these states in RDF (bug 559505).

Comment 11

8 years ago
My mistake, the problem was not caused by the Destroy the web addon, it was caused by Norton Toolbar. The problem with the home button was resolved when I removed the following incompatible addons:

Pixlr Grabber

Stylish

PDF Download

After removing these addons, the problem is resolved, and since I removed them at the same time I am not sure about which one of these addons caused it.

Comment 12

8 years ago
I am also experiencing this issue. After moving the home button back to the left, between the nav and address areas, it will, after (as far as I can tell) a random number of restarts, move back to the new default position on the right.

I do not criticize that the default position has been changed. However, if I decide to customize my toolbar, it should stay customized permanently.
void: any addons installed? if so, which?
(In reply to comment #11)
> Pixlr Grabber
> 
> Stylish
> 
> PDF Download
> 
> After removing these addons, the problem is resolved, and since I removed them
> at the same time I am not sure about which one of these addons caused it.

Vari97, can you re-enable them one by one and try to narrow it down? That'd be a huge help.
So far I haven't been able to reproduce this, so I'm minusing the blocking request because we don't seem to have steps to reproduce and do have indications that it might be related to a specific add-on.
blocking2.0: ? → -

Comment 16

8 years ago
Created attachment 503311 [details]
List of addons installed, with PDF Downloader causing the problem

After enabling PDF Downloader, the problem reappears, so I am pretty sure that it is caused by PDF Downloader. this is the list of other addons I have installed.
(Reporter)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Why was this marked FIXED?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Should have been resolved invalid; this is due to add-ons. If there's something add-ons do that triggers this specific problem, the bug should either morph to reflect that or a new bug should be filed.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.