nsTArray class depends on invalid unqualified lookup into dependent bases of class templates

RESOLVED FIXED in mozilla2.0b10

Status

()

defect
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: espindola, Assigned: espindola)

Tracking

Trunk
mozilla2.0b10
x86_64
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Posted patch Add "this->" (obsolete) — Splinter Review
xpcom/glue/nsTArray.h expects to be able to access dependent base classes members without adding a this->prefix.

The issue is explained in http://clang.llvm.org/compatibility.html#c++
Blocks: clang-macosx
Hardware: x86 → x86_64

Comment 1

9 years ago
The reporter's summary and initial comment were both lame. I'm merely adjusting the summary and providing a better link. I am not passing judgement on the quality of the bug report.

http://clang.llvm.org/compatibility.html#dep_lookup_bases
Summary: Depends on invalid unqualified lookup into dependent bases of class templates → nsTArray class depends on invalid unqualified lookup into dependent bases of class templates
Attachment #500366 - Attachment is obsolete: true
Attachment #500366 - Flags: review?(benjamin)

Updated

9 years ago
Attachment #501421 - Flags: review?(benjamin)
Attachment #501421 - Flags: review+
Attachment #501421 - Flags: approval2.0+
Assignee: nobody → respindola

Comment 4

9 years ago
http://hg.mozilla.org/mozilla-central/rev/e4c5d72fca11
Status: NEW → RESOLVED
Closed: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b10
You need to log in before you can comment on or make changes to this bug.