overlapping text on main deal at touch.groupon.com

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
8 years ago
4 years ago

People

(Reporter: tchung, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [websitecompatibility], URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 500371 [details]
overlaying text on groupon screenshot

Screenshot says it all.   Some kind of text overlay issue.

This doesnt reproduce on Android browser.

Repro:
1) launch fennec nightly 12/30 build.  (i used nexus one, thomas had a droid 2)
2) visit URL, click see this deal
3) scroll down, and click "more about this deal"
4) Verify the fine print overlays the main coupon

Expected:
- more about this deal should shift the page down to show the fine print details

Actual:
- ugly text overlays
(Reporter)

Updated

8 years ago
tracking-fennec: --- → ?
Matt, could it be a side effect of text reflow?

Updated

8 years ago
OS: Mac OS X → Android
Hardware: x86 → ARM
(In reply to comment #0)
> Created attachment 500371 [details]
> overlaying text on groupon screenshot
> 
> Screenshot says it all.   Some kind of text overlay issue.
> 
> This doesnt reproduce on Android browser.
> 
> Repro:
> 1) launch fennec nightly 12/30 build.  (i used nexus one, thomas had a droid 2)
> 2) visit URL, click see this deal
> 3) scroll down, and click "more about this deal"
> 4) Verify the fine print overlays the main coupon
> 
> Expected:
> - more about this deal should shift the page down to show the fine print
> details
> 
> Actual:
> - ugly text overlays

Tony, did you zoom in at all?
tracking-fennec: ? → 2.0+
(Reporter)

Comment 3

8 years ago
nope, no zoom at all.  touch.groupon.com seems to be the mobile version of groupon.  i can still reproduce this with steps from comment 0 on the 1/6/2011 build.
(Reporter)

Comment 4

8 years ago
(In reply to comment #3)
> nope, no zoom at all.  touch.groupon.com seems to be the mobile version of
> groupon.  i can still reproduce this with steps from comment 0 on the 1/6/2011
> build.

additional info: toggling Reformat Zoom on Text option to On or OFF doesnt matter.  still can reproduce either way.
From what I can see in the page source, this mobile website uses a few <div>s to create a stack of pages. The is the main page, the list of cities page and the more info page. They are all stacked on top of each other, but only one is supposed to be visible.

Somehow, the backgrounds are transparent (or something) and multiple pages are showing through each other. That causes the "overlay" effect.
I can reproduce on desktop Linux build, so I'll try using DOM Inspector to dig around.
Damn, DOMi and e10s don't mix yet :(
However, this also happen in desktop Firefox!

Looks like two positioned divs (positioned on top of each other) are both | display: block | because they are both | class="current *" |

There is a lot of webkit specific code in the website. Might be part of the problem. Can we contact someone at Groupon to fix this?
(Reporter)

Comment 9

8 years ago
(In reply to comment #8)
> However, this also happen in desktop Firefox!
> 
> Looks like two positioned divs (positioned on top of each other) are both |
> display: block | because they are both | class="current *" |
> 
> There is a lot of webkit specific code in the website. Might be part of the
> problem. Can we contact someone at Groupon to fix this?

Sunil Gupta!
Whiteboard: [websitecompatibility]
evangelism bugs don't block
Assignee: nobody → english-us
tracking-fennec: 2.0+ → ---
Component: General → English US
Product: Fennec → Tech Evangelism
QA Contact: general → english-us
Version: Trunk → unspecified

Updated

4 years ago
Assignee: english-us → nobody
Component: English US → Mobile
I see no problems now
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Updated

4 years ago
See Also: → bug 945943
You need to log in before you can comment on or make changes to this bug.