Closed Bug 622152 Opened 10 years ago Closed 10 years ago

Crash when clicking "Get More Information" in "about:privatebrowsing" with WebGL enabled on Linux [@ libc-2.12.1.so@0x33ba5] X_FreeGC: BadGC (invalid GC parameter); 3 requests ago

Categories

(Core :: Canvas: WebGL, defect)

All
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 621699

People

(Reporter: aaronmt, Unassigned)

References

()

Details

(Keywords: crash, regression, Whiteboard: [mozmill])

Crash Data

User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b9pre) Gecko/20101230 Firefox/4.0b9pre
Built from http://hg.mozilla.org/mozilla-central/rev/ec3e4786877d

[New Thread 0x7fe6a85f9710 (LWP 4265)]
[New Thread 0x7fe68effe710 (LWP 4266)]

Program received signal SIGABRT, Aborted.
0x00007fe6b9e48ba5 in raise () from /lib/libc.so.6
(gdb) bt
#0  0x00007fe6b9e48ba5 in raise () from /lib/libc.so.6
#1  0x00007fe6b9e4c6b0 in abort () from /lib/libc.so.6
#2  0x00007fe6bcffff46 in mozalloc_abort(char const*) () from ./libmozalloc.so
#3  0x00007fe6be49c401 in NS_DebugBreak_P () from ./libxul.so
#4  0x00007fe6bda0271a in ?? () from ./libxul.so
#5  0x00007fe6ba97ae24 in _XError () from /usr/lib/libX11.so.6
#6  0x00007fe6ba98130c in ?? () from /usr/lib/libX11.so.6
#7  0x00007fe6ba981d07 in _XEventsQueued () from /usr/lib/libX11.so.6
#8  0x00007fe6ba96a3fd in XPending () from /usr/lib/libX11.so.6
#9  0x00007fe6bbd252a6 in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#10 0x00007fe6bacb0a11 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#11 0x00007fe6bacb0e78 in ?? () from /lib/libglib-2.0.so.0
#12 0x00007fe6bacb145c in g_main_context_iteration ()
   from /lib/libglib-2.0.so.0
#13 0x00007fe6be305d35 in ?? () from ./libxul.so

failed to create drawable
failed to create drawable
###!!! ABORT: X_FreeGC: BadGC (invalid GC parameter); 3 requests ago: file /builds/slave/cen-lnx64-ntly/build/toolkit/xre/nsX11ErrorHandler.cpp, line 190
_XError+0x000000F4 [/usr/lib/libX11.so.6 +0x00043E24]
UNKNOWN [/usr/lib/libX11.so.6 +0x0004A30C]
_XEventsQueued+0x00000037 [/usr/lib/libX11.so.6 +0x0004AD07]
XPending+0x0000005D [/usr/lib/libX11.so.6 +0x000333FD]
UNKNOWN [/usr/lib/libgdk-x11-2.0.so.0 +0x0005A2A6]
g_main_context_prepare+0x000001A1 [/lib/libglib-2.0.so.0 +0x00043A11]
UNKNOWN [/lib/libglib-2.0.so.0 +0x00043E78]
g_main_context_iteration+0x0000006C [/lib/libglib-2.0.so.0 +0x0004445C]
UNKNOWN [./libxul.so +0x00F00D35]
UNKNOWN [./libxul.so +0x00F00F98]
UNKNOWN [./libxul.so +0x01090CB3]
UNKNOWN [./libxul.so +0x0105E27E]
UNKNOWN [./libxul.so +0x00FB0874]
UNKNOWN [./libxul.so +0x010C1CBE]
UNKNOWN [./libxul.so +0x00F010A5]
UNKNOWN [./libxul.so +0x00DC0909]
XRE_main+0x000021B8 [./libxul.so +0x005F69C2]
UNKNOWN [./firefox-bin +0x00001B48]
__libc_start_main+0x000000FE [/lib/libc.so.6 +0x0001ED8E]
UNKNOWN [./firefox-bin +0x00001909]
###!!! ABORT: X_FreeGC: BadGC (invalid GC parameter); 3 requests ago: file /builds/slave/cen-lnx64-ntly/build/toolkit/xre/nsX11ErrorHandler.cpp, line 190

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=24b63f638579&tochange=e928817fb4e9

Report:
http://crash-stats.mozilla.com/report/pending/a721fd91-7081-47fc-a787-9f5cf2101230

Same signature as bug 576933

Mozmill test that triggers the crash:
http://hg.mozilla.org/qa/mozmill-tests/file/43f2fb3d66b9/firefox/testPrivateBrowsing/testAboutPrivateBrowsing.js

Manual STR:

Get a recent (28th->) linux build:

Mozilla/5.0 (X11; Linux x86_64; rv:2.0b9pre) Gecko/20101230 Firefox/4.0b9pre

Make sure |webgl.enabled_for_all_sites| is enabled (default)

1. Enter Private Browsing mode
2. Click more information (Learn More link)
Asking for blocking because we have a regression from a blocking bug.
blocking2.0: --- → ?
Keywords: regression
Hardware: x86 → All
Summary: Crash [@ libc-2.12.1.so@0x33ba5] with WebGL enabled on Linux → Crash when clicking "Get More Information" in "about:privatebrowsing" with WebGL enabled on Linux [@ libc-2.12.1.so@0x33ba5]
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Summary: Crash when clicking "Get More Information" in "about:privatebrowsing" with WebGL enabled on Linux [@ libc-2.12.1.so@0x33ba5] → Crash when clicking "Get More Information" in "about:privatebrowsing" with WebGL enabled on Linux [@ libc-2.12.1.so@0x33ba5] X_FreeGC: BadGC (invalid GC parameter); 3 requests ago
Duplicate of bug: 621699
No longer blocks: 578877
blocking2.0: ? → ---
Crash Signature: [@ libc-2.12.1.so@0x33ba5]
You need to log in before you can comment on or make changes to this bug.