mozilla -console (or similar) only opens browser window

VERIFIED DUPLICATE of bug 58523

Status

P3
normal
VERIFIED DUPLICATE of bug 58523
18 years ago
10 years ago

People

(Reporter: neil, Assigned: don)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
1. Launch mozilla
2. Edit/Preferences/Appearance
3. Check Navigator and Mozilla Mail
4. Exit
5. Launch mozilla -console

Expected results: navigator and mozilla mail (and console)

Actual results: navigator only (and console)

Additional information:

As per the URL, the general startup prefs are only heeded if argc == 1.
However, the general startup code looks for -height and -width parameters.
These parameter will also inhibit the general startup prefs.
Instead, I believe the following steps should occur:
1. Always call DoCommandLines to process arguments
2. If no windows were created, follow the general startup prefs
3. If there are still no windows, create a browser window.

Presumably you would copy the Ensure1Window function, move the prefs code from
HandleArbitraryStartup into the new function and call it after DoCommandLines.
prolly the same as bug 58523.

*** This bug has been marked as a duplicate of 58523 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

18 years ago
You might want to change the summary of bug 58523 to something like

Appearence preferences ignored unless command line is empty

Comment 3

18 years ago
Verifying this as a duplicate of bug 58523.
'-P, -nosplash switches unable to launch anything other than the browser'
(expected: upon launch, mail, editor and browser windows should appear.
 result: only the browser window appears.)
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: Cmd-line Features → Cmd-line Features
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.