Extending String.prototype DNW

RESOLVED DUPLICATE of bug 610973

Status

()

Core
JavaScript Engine
--
major
RESOLVED DUPLICATE of bug 610973
7 years ago
7 years ago

People

(Reporter: Erik Vold, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
When I use the html file here: https://gist.github.com/760601 in any browser any version, other than Minefield it works fine, when I use the file in Minefield however I get the following error:

"".erik is not a function
http://localhost:8500/mvapp-dev/testII.html
Line 8

If I then type the following code into the Firebug Console:
alert(typeof "".erik)

Then the alert is "function" which is expected.. so I'm very confused why I get the error above..
That file works fine for me.  What build are you seeing the problem in?  Do you still see the problem if you disable or uninstall Firebug?

Comment 3

7 years ago
Dup, seems to me, reopen if I marked over-hastily.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 610973
You need to log in before you can comment on or make changes to this bug.