Last Comment Bug 622400 - Download-File with special characters in name will be saved with wrong name (RANDOM.part)
: Download-File with special characters in name will be saved with wrong name (...
Status: RESOLVED INCOMPLETE
:
Product: Firefox
Classification: Client Software
Component: File Handling (show other bugs)
: 3.6 Branch
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://vx.netlux.org/hh86/
Depends on: 475008
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-02 03:17 PST by mkrenn87
Modified: 2014-01-23 01:45 PST (History)
6 users (show)
manuela.muntean: needinfo? (mkrenn87)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description mkrenn87 2011-01-02 03:17:24 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 (.NET CLR 3.5.30729)

Trying to download a file called ";).rar" leads to wrong name in the download-box: "PNpJLb5C.part" or "DpA5gNtH.part", or "j78NWls5.part"...

(Clicking that file with left-click leads to binary data in the firefox-window - which is the second bug in that connection)

Reproducible: Always

Steps to Reproduce:
1. Click right at the download-link
2. Select "Save File As" (german: "Ziel speichern unter")
3. The Download-Box writes "PNpJLb5C.part" or "DpA5gNtH.part", or "j78NWls5.part"


Actual Results:  
Wrong name in the Download-Box.

Expected Results:  
Name ";).rar" in the Download-Box.

Reproducable every time, problem should be very easy to find.

Caution: The file in the example URL contains virus-writing information, so your AV may give you a warning. Just dont open .EXE files within the .RAR - then everything is good. (I dont have a webspace where I can put a living example with a different .RAR - sorry)
Comment 1 Jo Hermans 2011-01-02 03:54:06 PST
Maybe bug 475008, if the ";)" in the filename is causing a problem.
Comment 2 strayan 2011-04-21 23:21:00 PDT
This bug has remained unfixed since Firefox 3.
Comment 3 Manuela Muntean [Away] 2014-01-15 06:52:04 PST
Reporter, are you still seeing this issue with a latest Firefox version, considering http://vx.netlux.org/hh86/ is an invalid URL now?
Comment 4 Manuela Muntean [Away] 2014-01-23 01:45:54 PST
Incomplete due to lack of response. Please reopen the bug if you still see this issue.

Note You need to log in before you can comment on or make changes to this bug.