Closed Bug 62260 Opened 20 years ago Closed 19 years ago

WinME: Sending new mail with attachment doesn't work

Categories

(MailNews Core :: Composition, defect, P3)

x86
Windows ME
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 55591

People

(Reporter: scb147, Assigned: bugzilla)

Details

When I try to send a new mail message with an attachment, I get "Sending of
message failed."  I am aware of bug 62226, but even if I use an address that is
in my address book, I still get this error.  Once I remove the file attached,
the message will send with no problems. I also created a new profile and the
same happened.

I don't know if bug 62226 is related to this or not.

Steps to Reproduce:
1. Click on New Msg
2. Put an address from the address book in the To: field
3. Add an attachment
4 [details] [diff] [review]. Type subject/msg body.
5. Click Send

Actual Results:
An Alert box comes up and says "Sending of message failed" and the message won't
send. You can't even save a draft copy of it.

Expected Results:
The mail message is sent with the attachment

OS: WinME
Moz Build: 2000120704 Win32 Talkback
User Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; m18) Gecko/20001207
I've tried it with today's build 2000120804 Win32 talkback, and it still happens.
Anyone else?
Are you using a specific attachment? Have you tried with Windows 95/98 or NT?
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → mozilla0.9
OS: Win2k SP1
Moz Build: 2000120804 Win32 Talkback
User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m18) Gecko/20001208

This WFM using this configuration.  I will try again on Monday with my WinME
system and with this build to see if it happens again.
OS: WinME
Moz Build: 2000121104 Win32 talkback
User Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; m18) Gecko/20001211

I am now at work and I have downloaded the latest build and it still didn't work
here.  I even went back to Moz build 2000120804 Win32 Talkback, which worked on
Win2k SP1, and it still didn't work on WinME.  
Summary: Sending new mail with attachment doesn't work → WinME: Sending new mail with attachment doesn't work
changing milestone to unknown.  It will get changed back when we figure out what
milestone to put this bug in.
Target Milestone: mozilla0.9 → ---
I can confirm this on Windows NT 4.0 together with Mozilla 0.8.  Extremely annoying.
BTW, forwarding a message containing an attachment works OK.  It's just when you
attach something while composing a new message that it doesn't work.

Also, I get two (2) "Sending of message failed" dialogs, not one.

The attachment I attempted to send was a text file.
Reading the comments to bug 65703 from "Dave" and "Oliver Klee" from 2001-02-22
indicates that that bug may very well be related to this one.  As I'm only using
Mozilla for mail at work I can't test this until monday, but bug 65703 suggests
that setting "Use secure connection (SSL)" for the SMTP server to "Never" should
get mail sending working again.  If that is the case, this bug should probably
be set as a duplicate of bug 65703.

This is not a dupe; switching off SSL for sending mail doesn't help.
Since forwarding a mail with an attachment works, I attempted to:
1. Select a random mail.
2. Forward it.
3. Add a new attachment.

It didn't work though :-(.

Also, the summary should be updated to include Windows NT version 4 (as that's
what I'm using).  I would also like to change the severity to major, as I find
not being able to send mail with attachments quite a severe limitation, but I'm
not allowed to do that (which btw may be just as well ;-).

I don't think this is limited to WinME. I have very similar problems on Win98SE,
mainly sending multiple attachments, but has happened with single attachments as
well (may depend on the file type). Sometimes I get the "Sending failed" alert,
sometimes the mail window status bar gets stuck on "Sending message". When this
happens and I kill my connection, the compose window reappears. Setting the SSL
prefs and killing PSM didn't help me either. There are no error messages in the
console log that indicate any problem.

I receive pop mail for multiple accounts and send through a single smpt server,
dial-up account, no proxy. Been having this problem on every build of the last
couple of weeks, never had it before then. Currently on 2001030505.
This is intermittent (at least on Windows NT 4.0).  When I tried to send an
e-mail with two attachments just now it worked fine.  I have no idea what might
trigger this or under what conditions it works :-(.
FYI: Send message was broken between Feb 21 and March 8, we were randomly
loosing blocks of the transmission!
As of Mozilla 0.8.1 under Windows NT 4.0 with service pack 4, this bug is
(still) present.  While it's not working (as I said before it is intermittent),
I have tried to attach one Excel document (sending failed), one text document
(sending failed) and two text documents (sending failed).  So the number of
attachments doesn't seem to matter, and neither does the type.  Two "Sending of
message failed" boxes appear after each other when the sending has failed. 
Saving the message as a draft (to a local folder) doesn't work either.  I'm
using IMAP over SSL for *reading* mail, but plain SMTP for sending mail.
I have successfully sent an attachment.  When sending an attachment that comes
from a local drive (c:\johan.xls) things worked fine.  When sending the same
file from a network path \\othercomputer\adgagd\shaghrws\johan.xls I couldn't
send the e-mail.

It would be great if someone other than me could confirm this behaviour.
we already have a bug for Microsoft Network attachment failure! This is a known
issue.
This is a duplicate of bug 55591.  Someone authorized should mark this as redundant.

*** This bug has been marked as a duplicate of 55591 ***
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
verified dup
verified
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.