All users were logged out of Bugzilla on October 13th, 2018

document.write'd documents do not render background colors on tables

RESOLVED DUPLICATE of bug 60672

Status

()

P3
normal
RESOLVED DUPLICATE of bug 60672
18 years ago
18 years ago

People

(Reporter: mtierney, Assigned: jst)

Tracking

({testcase})

Trunk
x86
Windows NT
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(5 attachments)

(Reporter)

Description

18 years ago
The URL above demonstrates the scroll bar problem, and I have a small 2-HTML 
set (I'll try to attach to this bug later?) that demonstrates both that and the 
background color problem (neither the deprecated-but-supported bgcolor on TD's 
nor CSS work).  It occurs on both NSCP6 AND Mozilla M18, 2000120704.  This 
problem prevents my company from using NSCP6/Mozilla as an application client, 
leaving IE5.5 as the only 'modern' alternative for our customers.
(Reporter)

Comment 1

18 years ago
Created attachment 20307 [details]
main frameset for test routine
(Reporter)

Comment 2

18 years ago
Created attachment 20308 [details]
'driver' page for test
(Reporter)

Comment 3

18 years ago
I probably should have zipped those up, but basically, you can Save Target As 
those two scripts to the same directory, then run testmain.html to demonstrate 
the problem.  It runs fine as is on IE5, it also works fine on NSCP4.7 if you 
include a SRC="about:" or somesuch on the second frame in test.html.  
Mozilla20001207/NSCP6 no go..
bug 55334 covers the lack of scrollbars.  I can see the lack of a background...
Changing summary to focus on the background issue.  Attaching a testcase that
sets background colors on the body, a div, table, tr, and td.  The body, div and
td color are set, but the tr and table are not.
Summary: document.write'd documents do not render scroll bars or background colors → document.write'd documents do not render background colors on tables
Created attachment 20311 [details]
page with script for testcase
Created attachment 20314 [details]
HTML that is written to the dynamic frame by the testcase

Comment 8

18 years ago
Do you like to see a working example? Then take a look at this:
-----------------------------------------------------------------------------
http://members.chello.nl/~j.c.drost/mozilla/sm62263-f.html (frameset)
http://members.chello.nl/~j.c.drost/mozilla/sm62263-1.html (generator page)
http://members.chello.nl/~j.c.drost/mozilla/sm62263-2.html (stripped version)

Output almost 100% the same in in several browsers!

Using a stylesheet, bgcolor= and style= for the background.
Using a stylesheet, bgcolor= and style= for table data.
About the scroll bars:
In frameset, the scroller is set to 'auto', and thus no need for a This because
the the table size a 100% of the current window! So whatever size, fix it!
Seems to mee that, SM is doing the right job for this!

And please use a valid DTD in your documents! Like:
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">

and:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN"
"http://www.w3.org/TR/REC-html40/frameset.dtd">

Problems try this first: validator.w3.org/check (a must do)

Your W3C Validator,
Friendly, HJ.
HJ, I'd like to point out that your example uses backgrounds on body and td,
which as I said work.  But backgrounds on tr and table do _not_.  Providing a
workaround is nice, but does not fix the bug at hand.  Downgrading severity to
normal, though, since the background issue is not a major loss of function and
has a workaround.
actually changing severity to normal... 
Severity: major → normal

Comment 11

18 years ago
Hey Boris, take a look at this two:

http://members1.chello.nl/~j.c.drost/mozilla/sm62263-f3.html (frameset)
http://members1.chello.nl/~j.c.drost/mozilla/sm62263-3.html

I'm using <table> and <tr> for background colors of the table, and tr rows
In this working example, I took out the <TD> color stuff.

What seems to be the problem? Let me know Ok.
Please clarify,
Friendly, HJ!
HJ, I just looked at the links provided and you're setting colors on the td
elements!  Also, what's with the nested tables?  The outer table serves no
purpose...
seeing this, over to layout for initial triange
Assignee: asa → clayton
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout
Ever confirmed: true
QA Contact: doronr → petersen

Comment 14

18 years ago
Boris, You are right, As in seems I put the wrong one on the server!?
The good working one is now overwritten!
It's did work, for now, I will bring a new one up in minuts, will be back
in a moment

Friedly, HJ.

Comment 15

18 years ago
OK Boris, how are you B.T.W.

Here is an working example. Now the links are updated. Sorry for the error, but
I did work for 18 hours on a row, and then you know what might happen. And it did.

This is what I found:
The case in your example is that the usage of 'parent.frames[1].document' seems
 to be illegal. There is no object to it. So what I did is a small change of the
Frameset. I'm opening a document called empty.html in the Frameset as frames[1].
So now the object parent.frames[1].document is valid, after using open(); As you
will see, it's working perfecty now. Hope to help you this way.

And hope to find a solution for the scrollers too! I did see them at start!
Thats why the table nesting was inside the file! Will let you know a.s.a.p.

Your W3C validator,
friendly, HJ.
Upon managerial request, adding the "testcase" keyword to 84 open layout bugs that
do not have the "testcase" keyword and yet have an attachement with the word
"test" in the description field. Apologies for any mistakes.
Keywords: testcase
Please triage.
Assignee: clayton → jst
(Assignee)

Comment 18

18 years ago
Marking as a dup of bug 60672 that is about the table background problem, the
lack of scrollbars is coverd by bug 55334.

*** This bug has been marked as a duplicate of 60672 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.