Closed Bug 622867 Opened 10 years ago Closed 10 years ago

JSD throws exception when initializing debugger service because it calls obsolete method

Categories

(Other Applications Graveyard :: Venkman JS Debugger, defect, P1)

defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 614557

People

(Reporter: morac, Unassigned)

Details

When trying to run the JavaScript Debugger add-on in Firefox 4.0b7 or later, I get the following exception:

An exception occurred while initializing, please file a bug.
[Exception... "Component returned failure code: 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [jsdIDebuggerService.on]"  nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame :: chrome://venkman/content/venkman-debugger.js :: initDebugger :: line 131"  data: no]


The add-on is calling the jsdIDebuggerService.on method, but that method is no longer supported according to the IDL file, http://mxr.mozilla.org/mozilla-central/source/js/jsd/idl/jsdIDebuggerService.idl#221

The asyncOn method must be called instead of the on method.  So basically it never turns the debugger service on so it doesn't work.  

The change to the debugger service was made back in October by bug 595243.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 614557
V.Duplicate
Status: RESOLVED → VERIFIED
Product: Other Applications → Other Applications Graveyard
You need to log in before you can comment on or make changes to this bug.