images that are links don't activate

RESOLVED DUPLICATE of bug 65917

Status

()

Core
CSS Parsing and Computation
P3
normal
RESOLVED DUPLICATE of bug 65917
18 years ago
17 years ago

People

(Reporter: Michael Nahrath, Assigned: Pierre Saslawsky)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
build 2000120708, MacOs 9.0.4-D:

If an anchor element contains an image, the defined style rules for ':active'
are not triggered if you click on the image.
If the anchor contains text _and_ an image, klicking the text triggers the
CSS-action for both.

Example:
<a href="uri1">some text <img src="uri2"></a>

You may check this at <http://www.subotnik.net> with the Link "MacFAQ"
aside the banner near the bottom of th page.

Defining the rule for :active, :active IMG, :link:active, a:active, ...
makes no difference.
(Reporter)

Comment 1

18 years ago
Seems like this is not only a CSS issue.
Even with plain 'HTML 4 transitional'images hover to textcolour if you first
touch them and don't react on activation.

I created a simple testcase to illustrate this:
<http://www.subotnik.net/test/a-img-1.html>
Keywords: testcase
Summary: CSS :active has no effect on images that are links → images that are links don't activate
cc'ing dbaron as the test case is his

Comment 3

18 years ago
Verified
Platform: PC
OS: Linux 2.2.16
Mozilla Build: 2000121908 M18 Trunk Build.


I am going ahead and Marking this NEW because I only see a bug reporting
activate problems with text input areas.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac System 9.x → All
Hardware: Macintosh → All
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian

Comment 5

17 years ago
I think this is a duplicate of bug 65917.
(Assignee)

Comment 6

17 years ago


*** This bug has been marked as a duplicate of 65917 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.