Cannot start Firefox from command line under Leopard

RESOLVED WONTFIX

Status

()

Firefox
General
--
major
RESOLVED WONTFIX
7 years ago
6 years ago

People

(Reporter: BugzillaJade.5.JadeNB, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; en-us) AppleWebKit/533.19.4 (KHTML, like Gecko) Version/5.0.3 Safari/533.19.4
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0b8) Gecko/20100101 Firefox/4.0b8

I used to start Firefox (certainly pre-4.0 builds, and I think early 4.0 betas) from the command line, since I can't figure out how otherwise to have multiple different profiles running simultaneously.  Even if there's a work-around, I still miss the ability.  It broke no later than 4.0b7, but possibly earlier; I may have missed some betas.

I have reported this as major because I think not being able to start the software from the command line is; but, since it starts fine via the 'usual Mac route', maybe it's merely normal.  Also note that this is Firefox-specific; Thunderbird 3.1.7, for example, will start just fine.

Reproducible: Always

Steps to Reproduce:
1. On the command line, enter $ $FIREFOX_PATH/Contents/MacOS/firefox-bin
Actual Results:  
The following message appears:
{{{
dyld: unknown required load command 0x80000022
Trace/BPT trap
}}}

Expected Results:  
Firefox starts.

Some Googling (http://www.google.com/search?q=dyld+0x80000022) suggests that this is a problem with running software on Leopard that was compiled under Snow Leopard; see, for example, http://discussions.apple.com/thread.jspa?threadID=2151112.
(Reporter)

Updated

6 years ago
Duplicate of this bug: 637213
(Reporter)

Comment 2

6 years ago
This is still an issue with 4.0b12.  It doesn't occur with 3.6.13.

Comment 3

6 years ago
I'm also seeing this with OS X 10.5/Leopard and beta12. I stumbled across it while setting up a profile for extension development, as mentioned at https://developer.mozilla.org/en/Setting_up_extension_development_environment

[jwm@hobbes:s005 ~> uname -a
Darwin hobbes 9.8.0 Darwin Kernel Version 9.8.0: Wed Jul 15 16:55:01 PDT 2009; root:xnu-1228.15.4~1/RELEASE_I386 i386 i386
[jwm@hobbes:s005 ~> /Applications/Firefox\ 4b12.app/Contents/MacOS/firefox-bin -no-remote -P dev 
dyld: unknown required load command 0x80000022
Trace/BPT trap
Josh: any idea what this might be or if it's a serious problem for RC?

Comment 5

6 years ago
Build identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0) Gecko/20100101 Firefox/4.0

I just updated from Firefox 4.0beta12 to 4.0. This error still occurs for me.

Comment 6

6 years ago
Firefox 4 is a universal binary with i386 and x86_64 components. When you launch the binary in that way the OS prefers the x86_64 component, which for us is incompatible with Mac OS X 10.5. The result is a crash. This doesn't happen when you double click the app because in that case the OS checks the Info.plist file for architecture preferences.

When you're launching from the command line you need to specify a preference for i386 on Mac OS X 10.5. You do this with the "arch" utility - prefix the command you'd normally use with "arch -i386".
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.