Button doesn't not acquire focus when clicked

RESOLVED DUPLICATE of bug 577316

Status

()

Core
General
RESOLVED DUPLICATE of bug 577316
7 years ago
7 years ago

People

(Reporter: Alessandro Vernet, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b7) Gecko/20100101 Firefox/4.0b7
Build Identifier: 4.0b8

-

Reproducible: Always

Steps to Reproduce:
1. Load http://jsfiddle.net/avernet/Zm7Fx/
2. Set the focus in the input field. 
3. Click on the "Nothing" button.
Actual Results:  
The input still has the focus.

Expected Results:  
I would expect the button to acquire to the focus when clicked. This is what happened with previous versions (e.g. Firefox 3.6) and what happens with other browsers.
This was a purposeful change on Mac only; apparently on Mac the system behavior is to not focus buttons when they are clicked.

There is a preference you can set to get the old behavior.  See the discussion in bug 577316.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 577316
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> *** This bug has been marked as a duplicate of bug 577316 ***

Got it; thank you. I created Bug 623291, which is more specific, and I hope compatible with the decisions taken for bug 577316.
You need to log in before you can comment on or make changes to this bug.