If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

dragging text over the location bar indicates that the text will be inserted but dropping deletes the existing text

RESOLVED DUPLICATE of bug 250622

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 250622
7 years ago
6 years ago

People

(Reporter: karlt, Unassigned)

Tracking

Trunk
x86_64
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
When dragging text over the location bar a caret is shown at the drop point to indicate that text will be inserted at the caret.

This is not what happens when the text is dropped.

Expected Results:
The response to the drop is consistent with drag feedback.
For an insertion caret, i.e. text is inserted.

Actual Results:
When the text is dropped, the contents of the location bar are cleared.

Undo does not restore the contents of the location bar.

Reproducible on Linux and Win 7.
Similar behaviour with the search bar, but other XUL textboxes work as expected.
(Reporter)

Comment 1

7 years ago
Bug also exists on 1.9.2.
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 546378
(Reporter)

Updated

6 years ago
Duplicate of bug: 250622
You need to log in before you can comment on or make changes to this bug.