Closed Bug 623373 Opened 9 years ago Closed 9 years ago

ati x1900 on mac pro causing graphics glitches

Categories

(Core :: Graphics, defect, major)

x86
macOS
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 623852

People

(Reporter: adamprocter, Unassigned)

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b9pre) Gecko/20110105 Firefox/4.0b9pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b9pre) Gecko/20110105 Firefox/4.0b9pre

glitches on using ATI Radean x1900 graphics card on mac pro here is screen shot http://twitpic.com/3nce99

I also find Tabs disappear/flicker when you have a few open when you need to scroll tabs it mucks up and tabs disappear and flicker - not seen this until recent (ish) updates

on mac the close, max and min bar at the top now has a line that flickers between the bar and the firefox buttons this did not happen before. 

Reproducible: Always

Steps to Reproduce:
1.Open any page
2. scale browser window
3.
Actual Results:  
Screen is all messed up http://twitpic.com/3nce99 tabs are all messed up too
Please post the graphic section from about:;support here and disable the hardware acceleration under edit\preferences\advanced\general and restart Firefox..
Does that fix it ?
Adam, in our email conversation you have mentioned that it has been started recently. In that case it is very helpful when you could check for the regression range. Simply download the nighlty builds from the URL below and test on which day it has been started for you. In the about:buildconfig page you can find the changeset id's, which should be posted here.

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011/01/
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2010/12/

Also please run a quick test in Safe Mode before (http://support.mozilla.com/en-US/kb/Safe Mode) - but I don't think it will make a difference. Thanks.
Status: UNCONFIRMED → NEW
Component: General → Graphics
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → thebes
Version: unspecified → Trunk
Adam, this is very strange, because we actually block the X1000 series from using hardware acceleration on OS X for reasons very much like this.
I just found out my card is one of these http://support.apple.com/kb/ts3420  and so I need to contact apple re replacement and this issue could be related I will try and download older ones tho asap as it was recent - although thinking back I have had odd glitches in the past - maybe ill get a better card :D
I can confirm Firefox 4 beta 8 does not have the same issues - I got a little lost in trying the other download links.

I cam also confirm new user same problems

  Application Basics

        Name
        Firefox

        Version
        4.0b9pre

        User Agent
        Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b9pre) Gecko/20110106 Firefox/4.0b9pre

        Profile Directory

          Show in Finder

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

  Extensions

        Name

        Version

        Enabled

        ID

        Flashblock
        1.5.14.2
        true
        {3d7eb24f-2740-49df-8937-200b1cc08f8a}

  Modified Preferences

      Name

      Value

        accessibility.typeaheadfind.flashBar
        0

        browser.places.smartBookmarksVersion
        2

        browser.startup.homepage_override.buildID
        20110106030349

        browser.startup.homepage_override.mstone
        rv:2.0b9pre

        extensions.lastAppVersion
        4.0b9pre

        layers.accelerate-none
        true

        network.cookie.prefsMigrated
        true

        places.history.expiration.transient_current_max_pages
        193273

        privacy.sanitize.migrateFx3Prefs
        true

        security.warn_viewing_mixed
        false

  Graphics

        Adapter Description
        0x21900,0x20400

        Vendor ID
        0000

        Device ID
        0000

        Adapter RAM

        Adapter Drivers

        Driver Version

        Driver Date

        Direct2D Enabled
        false

        DirectWrite Enabled
        false

        WebGL Renderer
        ATI Technologies Inc. -- ATI Radeon X1900 OpenGL Engine -- 2.0 ATI-1.6.26

      GPU Accelerated Windows
      0/1
hardware off does not fix the issue
(In reply to comment #6)
> I can confirm Firefox 4 beta 8 does not have the same issues - I got a little
> lost in trying the other download links.

You should go to folders like:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2011/01/2011-01-01-03-mozilla-central/

Important is "mozilla-central". Then just download the mac64.dmg file and mount it. You can execute the application right away from inside the mounted dmg.
I can confirm that the bug is introduced in build 4.0b9pre 2011-01-03

Minefield dated 2011-01-02 works fine

Hope that helps (not my card after all)
Adam, can you please check about:buildconfig for both builds and copy&paste the changeset as comment? Thanks!
Cant see Changeset But this is  all the info from  

First - 2011-01-02

about:buildconfig
Source

Built from http://hg.mozilla.org/mozilla-central/rev/a05e91710adb
Build platform
target
i386-apple-darwin10.2.0
Build tools
Compiler 	Version 	Compiler flags
gcc-4.2 -arch i386 	gcc version 4.2.1 (Apple Inc. build 5646) (dot 1) 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -W -gdwarf-2 -isysroot /Developer/SDKs/MacOSX10.5.sdk -fno-strict-aliasing -fpascal-strings -fno-common -pthread -DNO_X11 -DNDEBUG -DTRIMMED -gdwarf-2 -O3 -fomit-frame-pointer
g++-4.2 -arch i386 	gcc version 4.2.1 (Apple Inc. build 5646) (dot 1) 	-fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -gdwarf-2 -isysroot /Developer/SDKs/MacOSX10.5.sdk -fno-strict-aliasing -fpascal-strings -fno-common -fshort-wchar -pthread -DNO_X11 -DNDEBUG -DTRIMMED -gdwarf-2 -O3 -fomit-frame-pointer
Configure arguments

--target=i386-apple-darwin10.2.0 --with-macos-sdk=/Developer/SDKs/MacOSX10.5.sdk --enable-application=browser --enable-update-channel=nightly --enable-update-packaging --enable-tests --enable-codesighs --disable-install-strip --enable-debug-symbols=-gdwarf-2
Source

Built from http://hg.mozilla.org/mozilla-central/rev/a05e91710adb
Build platform
target
x86_64-apple-darwin10.2.0
Build tools
Compiler 	Version 	Compiler flags
gcc-4.2 -arch x86_64 	gcc version 4.2.1 (Apple Inc. build 5646) (dot 1) 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -W -gdwarf-2 -isysroot /Developer/SDKs/MacOSX10.6.sdk -fno-strict-aliasing -fpascal-strings -fno-common -pthread -DNO_X11 -DNDEBUG -DTRIMMED -gdwarf-2 -O3 -fomit-frame-pointer
g++-4.2 -arch x86_64 	gcc version 4.2.1 (Apple Inc. build 5646) (dot 1) 	-fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -gdwarf-2 -isysroot /Developer/SDKs/MacOSX10.6.sdk -fno-strict-aliasing -fpascal-strings -fno-common -fshort-wchar -pthread -DNO_X11 -DNDEBUG -DTRIMMED -gdwarf-2 -O3 -fomit-frame-pointer
Configure arguments

--target=x86_64-apple-darwin10.2.0 --with-macos-sdk=/Developer/SDKs/MacOSX10.6.sdk --enable-application=browser --enable-update-channel=nightly --enable-update-packaging --enable-tests --enable-codesighs --disable-install-strip --enable-debug-symbols=-gdwarf-2


and this is all the info from 
Second - 2011-01-03

about:buildconfig
Source
Built from http://hg.mozilla.org/mozilla-central/rev/c20f34eefa5d
Build platform
target
i386-apple-darwin10.2.0
Build tools
Compiler
Version
Compiler flags
gcc-4.2 -arch i386
gcc version 4.2.1 (Apple Inc. build 5646) (dot 1)
-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -W -gdwarf-2 -isysroot /Developer/SDKs/MacOSX10.5.sdk -fno-strict-aliasing -fpascal-strings -fno-common -pthread -DNO_X11 -DNDEBUG -DTRIMMED -gdwarf-2 -O3 -fomit-frame-pointer
g++-4.2 -arch i386
gcc version 4.2.1 (Apple Inc. build 5646) (dot 1)
-fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -gdwarf-2 -isysroot /Developer/SDKs/MacOSX10.5.sdk -fno-strict-aliasing -fpascal-strings -fno-common -fshort-wchar -pthread -DNO_X11 -DNDEBUG -DTRIMMED -gdwarf-2 -O3 -fomit-frame-pointer
Configure arguments
--target=i386-apple-darwin10.2.0 --with-macos-sdk=/Developer/SDKs/MacOSX10.5.sdk --enable-application=browser --enable-update-channel=nightly --enable-update-packaging --enable-tests --enable-codesighs --disable-install-strip --enable-debug-symbols=-gdwarf-2

Source
Built from http://hg.mozilla.org/mozilla-central/rev/c20f34eefa5d
Build platform
target
x86_64-apple-darwin10.2.0
Build tools
Compiler
Version
Compiler flags
gcc-4.2 -arch x86_64
gcc version 4.2.1 (Apple Inc. build 5646) (dot 1)
-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -W -gdwarf-2 -isysroot /Developer/SDKs/MacOSX10.6.sdk -fno-strict-aliasing -fpascal-strings -fno-common -pthread -DNO_X11 -DNDEBUG -DTRIMMED -gdwarf-2 -O3 -fomit-frame-pointer
g++-4.2 -arch x86_64
gcc version 4.2.1 (Apple Inc. build 5646) (dot 1)
-fno-rtti -fno-exceptions -Wall -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-invalid-offsetof -Wno-variadic-macros -Werror=return-type -gdwarf-2 -isysroot /Developer/SDKs/MacOSX10.6.sdk -fno-strict-aliasing -fpascal-strings -fno-common -fshort-wchar -pthread -DNO_X11 -DNDEBUG -DTRIMMED -gdwarf-2 -O3 -fomit-frame-pointer
Configure arguments
--target=x86_64-apple-darwin10.2.0 --with-macos-sdk=/Developer/SDKs/MacOSX10.6.sdk --enable-application=browser --enable-update-channel=nightly --enable-update-packaging --enable-tests --enable-codesighs --disable-install-strip --enable-debug-symbols=-gdwarf-2
So that means it has been regressed between the following changesets:

PASS: http://hg.mozilla.org/mozilla-central/rev/a05e91710adb
FAIL: http://hg.mozilla.org/mozilla-central/rev/c20f34eefa5d

Check-ins: 
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a05e91710adb&tochange=c20f34eefa5d

There were a bunch of check-ins from Roc in this window. CC'ing him so we hopefully find the right bug without further testing.
I have reverted back to Firefox4 Beta8 for now (b9 not usable really useable). Happy to test when fixed.
Nothing obvious springs to mind. Maybe the next thing to do is to narrow it down to a particular change.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 623852
You need to log in before you can comment on or make changes to this bug.