Remove aCanBePercent parameter from nsAttrValue::ParseSpecialIntValue

RESOLVED FIXED in mozilla2.0b12

Status

()

Core
DOM: Core & HTML
--
trivial
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: Ms2ger, Assigned: Ms2ger)

Tracking

Trunk
mozilla2.0b12
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

7 years ago
Created attachment 501650 [details] [diff] [review]
Patch v1

All callers pass true.
Flags: in-testsuite-
Attachment #501650 - Flags: review?(peterv)
Comment on attachment 501650 [details] [diff] [review]
Patch v1

>diff --git a/content/html/content/src/nsGenericHTMLElement.cpp b/content/html/content/src/nsGenericHTMLElement.cpp

>-                                          const nsAString& aString,
>+                                          const nsAString& aValue,

Please undo this, it's unrelated to the main change and it muddies the blame.
Attachment #501650 - Flags: review?(peterv) → review+
(Assignee)

Comment 2

7 years ago
Comment on attachment 501650 [details] [diff] [review]
Patch v1

(In reply to comment #1)
> Comment on attachment 501650 [details] [diff] [review]
> Patch v1
> 
> >diff --git a/content/html/content/src/nsGenericHTMLElement.cpp b/content/html/content/src/nsGenericHTMLElement.cpp
> 
> >-                                          const nsAString& aString,
> >+                                          const nsAString& aValue,
> 
> Please undo this, it's unrelated to the main change and it muddies the blame.

Will do.
Attachment #501650 - Flags: approval2.0?

Updated

7 years ago
Attachment #501650 - Flags: approval2.0? → approval2.0+
(Assignee)

Comment 3

7 years ago
Created attachment 509461 [details] [diff] [review]
Patch for checkin

Thanks!
Attachment #501650 - Attachment is obsolete: true
(Assignee)

Updated

7 years ago
Keywords: checkin-needed

Comment 4

7 years ago
http://hg.mozilla.org/mozilla-central/rev/beb7483fcb5d
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b12

Comment 5

7 years ago
I backed this patch as part of this pushlog <http://hg.mozilla.org/mozilla-central/pushloghtml?changeset=7e12e3e16e6c> because of the oranges it caused <http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1296852850.1296854923.2345.gz&fulltext=1>.

I'm not sure which one of the bugs was at fault, so I just backed them all out.  The assignee needs to investigate and make sure that his patch has not been the culprit, and then re-add checkin-needed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Relanded all but one of the patches in that push.  For this bug, that's:
http://hg.mozilla.org/mozilla-central/rev/a65173888809
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Duplicate of this bug: 611064
You need to log in before you can comment on or make changes to this bug.