Last Comment Bug 623612 - South (the library we're using for migrations) isn't creating tables in the correct order.
: South (the library we're using for migrations) isn't creating tables in the c...
Status: RESOLVED WONTFIX
batucada
:
Product: Websites Graveyard
Classification: Graveyard
Component: www.drumbeat.org (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
https://github.com/paulosman/batucada
: 624761 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-06 08:15 PST by Paul Booker
Modified: 2015-01-30 07:54 PST (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Paul Booker 2011-01-06 08:15:53 PST
User-Agent:
Build Identifier:

Description:

If you follow the instruction on GitHub up to an including migrating the data with ..

  python manage.py migrate

.. the following errors are reported ..

DatabaseError: (1146, "Table 'batucada.projects_project' doesn't exist") [django development server]

raise errorclass, errorvalue
 _mysql_exceptions.OperationalError: (1050, "Table 'activity_remoteobject' already exists") [python interactive interpreter]

Reproducible: Always


Steps to reproduce:
Follow the instructions on GitHub up to an including
python manage.py migrate

Expected Results:
Data is migrated successfully

Actual Results:
See the reported errors under @description

Proposed solution:


Best,
Paul Booker
Appcost
Comment 1 Paul Osman [:paulosman] 2011-01-11 10:05:22 PST
*** Bug 624761 has been marked as a duplicate of this bug. ***
Comment 2 James Walker [:walkah] 2011-03-02 15:04:33 PST
I'm not able to reproduce this ... has it been fixed?
Comment 3 Kohei Yoshino [:kohei] 2013-11-10 01:22:21 PST
"The Drumbeat.org web site is winding down"

Note You need to log in before you can comment on or make changes to this bug.