Images improperly aligned - Javascript coordinates off

VERIFIED DUPLICATE of bug 5900

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 5900
19 years ago
19 years ago

People

(Reporter: Steve Halasz, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
The logo at upper right is split into two images. These images have a horizontal
space between them that I don't think ought to be there. Putting the same HTML
outside of a table will result in the two images being flush. Also, the
coordinates at which javascript rolls over the images do not correspond to the
locations or dimensions of the images.
(Reporter)

Updated

19 years ago
Component: Apprunner → Layout

Updated

19 years ago
Assignee: don → rickg

Updated

19 years ago
Assignee: rickg → karnaze

Comment 1

19 years ago
Chris -- there's two bugs here:  a verticle WS bug (for you) and a mouse over
bug (for Vidur I think). Please take a look, and forward to V when you;re done.

Comment 2

19 years ago
The vertical whitespace (gap) is a result of the <A><IMG></A> bug #5900
(a.k.a 'nav4 vs. css2 line layout'). This is true in my tests whether the
images are inside or outside a table cell. Removing the <A></A> "fixes" the
vertical whitespace problem.

 As for the javascript coordinates, the mouseover event is triggered a few
(1-3) pixels below the actual anchor/image location, but I suppose this may be
a consequence of the same <A><IMG></A> vertical spacing bug.

 skh2@cornell.edu: if you are referring to the events appearing to fire in the
'white-space' region to the right of the images, try setting 'BORDER=1' on IMG
and you can see that the 'white-space' is part of the images, and the events
fire at the correct coordinates. (Of course, you may be referring to something
else, and I may be using a different build to test this, and the problem may
appear differently in another build).

 Tested 1999051308 win95.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 3

19 years ago
*** This bug has been marked as a duplicate of 5900 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.