Closed Bug 623737 Opened 9 years ago Closed 9 years ago

When network connection is down, Sync reveals an 'update' link that tells me "Your Sync Key has changed"

Categories

(Firefox :: Sync, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: dholbert, Unassigned)

References

Details

Attachments

(1 file)

STEPS TO REPRODUCE:
 1. Disconnect from all networks and/or disable networking entirely.
 2. Start Firefox
 3. Tools | Sync Now
   --> A notification bar appears at the bottom, with a single large button labeled "Preferences".  Users like clicking buttons, so click the button.
 4. Now you see the preferences dialog, with "Connect" being the most obvious thing to click.  Click that.
 5. This makes the message appear (right below "connect" button)
     "Failed to connect to the server  [Update] [Reset]"
    "Reset" sounds scary, so let's click [Update].

ACTUAL RESULTS:
 A dialog appears saying:
====
   Your Sync Key has changed, please enter your new Sync Key
   Your Sync Key [__________________]
====

This is really bad, because it's definitively stating something that's not true ("Your Sync Key has changed"), and it's inviting me to type in a new value that for all I know will cause sync problems on this or other machines as soon as my network connection goes back up.
Mozilla/5.0 (X11; Linux x86_64; rv:2.0b9pre) Gecko/20110106 Firefox/4.0b9pre
Attached image screenshot
Hmm yeah, that's a bit stupid. Pretty sure I've already fixed this in bug 526445, but I'll leave this open until I verify this.
>  Pretty sure I've already fixed this in bug 526445,
In case it's not fixed by that bug: This bug probably stems from how Sync conflates multiple types of errors, as described in bug 623689 comment 9.  In this case, it's conflating
   "Something unexpected happened (e.g., network or server error)"
with
   "Your configuration is wrong (wrong sync key)".
Bug 526445 fixed this.
Status: NEW → RESOLVED
Closed: 9 years ago
Depends on: 526445
Resolution: --- → FIXED
Component: Firefox Sync: UI → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.