Save Image/Save Link not working

VERIFIED FIXED

Status

Firefox for Android Graveyard
General
--
major
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: ahoza, Assigned: mfinkle)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
BuildId: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b9pre) Gecko/20100107 Firefox/4.0b9pre Fennec /4.0b4pre 
and
Mozilla /5.0 (Maemo;Linux armv7l;rv:2.0b9pre) Gecko/20110107 Firefox/4.0b9pre
Fennec/4.0b4pre

STR:

1. Visit yahoo.com
2. Long tap on a image and choose "Save Image" from context menu.
3. Long tap on a link and choose "Save Link" from context menu.

Expected results:
Image/page should be saved on filesystem. 
I believe a dialog should be displayed as well, at the bottom of the page saying image/page will be saved. Also there should be entries for those 2 items in Downloads Manager

Actual results:
Nothing really seems to be happening
(Reporter)

Updated

8 years ago
tracking-fennec: --- → ?
Severity: normal → major
Created attachment 502008 [details] [diff] [review]
patch

Regression from splitting out the scripts. Nice catch!
Assignee: nobody → mark.finkle
Attachment #502008 - Flags: review?(mbrubeck)
(Assignee)

Updated

8 years ago
tracking-fennec: ? → 2.0b4+
Note: We don't show the dialog anymore. We removed that a while ago and just save directly to disk.
Attachment #502008 - Flags: review?(mbrubeck) → review+
pushed:
http://hg.mozilla.org/mobile-browser/rev/ad85c5f2f590
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

8 years ago
Verified as fixed with:
Mozilla /5.0 (Android;Linux armv7l;rv:2.0b9pre) Gecko/20110109
Firefox/4.0b9pre Fennec /4.0b4pre 
and
Mozilla /5.0 (Maemo;Linux armv7l;rv:2.0b9pre) Gecko/20110109 Firefox/4.0b9pre
Fennec/4.0b4pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.