Searches from URL bar should include source attribute

VERIFIED DUPLICATE of bug 596439

Status

()

VERIFIED DUPLICATE of bug 596439
8 years ago
6 years ago

People

(Reporter: limi, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

We currently don't have a way to track the new search location (URL bar searches, bug 565966) on the server side.

Currently, we do the following:

* Searches from toolbar search field: Normal search string
* Searches from Firefox Start home page: adds "&source=hp" to the search string
* Searches from Location Bar: same as toolbar search

Ideally, searches from the Location Bar should have a source attribute, I propose we add "&source=lb" for searches done here.

This is important for a couple of different reasons:
* Knowing what the percentage split between the two fields is for revenue purposes
* Be able to track the trend of people using the URL bar for search (which we hypothesize is becoming more common)
Requesting blocking since this is the last part of the changes done to the URL bar to enable search — the rest of the work was done in bug 565966 and bug 586821. 

Should be extremely low risk, and hopefully not a lot of work (string concatination? ;) as far as I can tell.
blocking2.0: --- → ?
Status: NEW → RESOLVED
blocking2.0: ? → ---
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 596439
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.