Closed Bug 624089 Opened 10 years ago Closed 10 years ago

RSS link that Thunderbird reports as a malformed URI.

Categories

(MailNews Core :: Feed Reader, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: jurko.gospodnetic, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10 ( .NET CLR 3.5.30729; .NET4.0E)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101207 Thunderbird/3.1.7

RSS link http://www.wireshark.org/lists/wireshark-announce.rss can be opened in a web browser and seems to be a completely valid URI but when attempting to subscribe to it in Thunderbird I get an error message in the Error Console stating that the given URI is malformed:

Error: uncaught exception: [Exception... "Component returned failure code: 0x804b000a (NS_ERROR_MALFORMED_URI) [nsIStandardURL.init]"  nsresult: "0x804b000a (NS_ERROR_MALFORMED_URI)"  location: "JS frame :: chrome://messenger-newsblog/content/FeedItem.js :: anonymous :: line 58"  data: no]

Reproducible: Always

Steps to Reproduce:
1. Start Thunderbird.
2. Show the Error Console (Tools/Error Console) - should be empty, and if not - clear it.
3. Make sure you have an RSS account available.
4. Make sure you have a folder available under the RSS account from step 3.
5. Select 'Subscribe' from a popup menu displayed when right-clicking on a folder from step 4.
6. Enter the URL 'http://www.wireshark.org/lists/wireshark-announce.rss' as the RSS feed source. Folder from step 4 should already be selected.

Actual Results:  
No error message will be displayed to the user. An error message will be displayed in the Error Console window. Setting up the RSS feed subscription will stall until canceled.

Expected Results:  
Set up the requested RSS feed subscription. If the URI is actually malformed - report this explicitly to the user.
It's not saying that http://www.wireshark.org/lists/wireshark-announce.rss is malformed, it's saying that the URI that we create from "<guid isPermaLink="true">Fri, 19 Nov 2010 20:24:12 GMT</guid>" (which is quite possibly the worst thing I have ever seen in a long career of looking at broken RSS feeds created by people who couldn't be bothered to read the spec) is malformed.

We did recently switch away from believing that <guid>garbage</guid> was the URI it is supposed to be, but we still believe that people won't say <guid isPermaLink="true">garbage</guid>.
Component: General → Feed Reader
Product: Thunderbird → MailNews Core
QA Contact: general → feed.reader
I can confirm that this is is not a bug in Thunderbird and was caused by an actual malformed RSS feed as described by Phil Ringnalda. Reported to the Wireshark project and already fixed (see http://bugs.wireshark.org/bugzilla/show_bug.cgi?id=5561). Now this same RSS feed gets subscribed to correctly by Thunderbird.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.