Closed Bug 624118 Opened 9 years ago Closed 9 years ago

No repainting of chrome + tab content

Categories

(Core :: Graphics, defect, major)

x86
macOS
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 623852

People

(Reporter: julian.viereck, Unassigned)

Details

Attachments

(2 files)

Steps to reproduce:
1) Open Minefield
2) Go to a page that has some content (this is just to demonstrate that you will not see this content later)
3) Open a bunch of new tabs using the keyboard shortcut. There have to be that many tabs, that the tabs don't fit into tab bar anymore and you have to scroll through the tabs to get to the last one.
4) Select the last tab.
5) Select the first tab with the former content page.

During these steps you will see the following rendering bugs:

1) As soon as the tabs don't fit into the tab bar anymore, the tabs are not painted correctly.
2) As you switch back to the content tab in step 5, the content of that tab is no displayed. Even worst, the scrollers are not displayed either. When you start scrolling on the page, the content and the scrollers are painted.

See also the enclosed screenshot.

Tested with latest Nightly, about:buildconfig says: "Built from http://hg.mozilla.org/mozilla-central/rev/f93c5678d642"

Tested using a MacBook first generation (MB 1,1).

Regression window: I haven't looked up the regression window, but I think I've noticed this behavior the first time one or two weeks ago.
Talking to robcee on IRC. Thought the problem might caused by new graphic acceleration, but the page says:

      GPU Accelerated Windows 0/1
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
This is bug 623852, which seems to only affect Mac without hardware accel.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 623852
You need to log in before you can comment on or make changes to this bug.