Closed Bug 624189 Opened 11 years ago Closed 11 years ago

18014398509481983 === 18014398509481984 ?

Categories

(Core :: JavaScript Engine, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 5856

People

(Reporter: tabutils+bugzilla, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b9pre) Gecko/20110108 Firefox/4.0b9pre
Build Identifier: 

alert(18014398509481983 === 18014398509481984);

true!?

Reproducible: Always
This is an artifact of IEEE754 double-precision arithmetic, see bug 5856.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: js-ieee-double-hurts
You need to log in before you can comment on or make changes to this bug.