Closed Bug 624285 Opened 12 years ago Closed 12 years ago

WebMoney Light web-interface doesn't prompt for certificate anymore

Categories

(Core :: Networking: HTTP, defect)

defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 624075

People

(Reporter: unghost, Unassigned)

References

()

Details

(Keywords: regression)

WebMoney Light web-interface (https://light.webmoney.ru/login.aspx) doesn't prompt for certificate anymore. I've narrowed down it to:

20110106 - http://hg.mozilla.org/mozilla-central/rev/c6e65b6259db - fail
20110105 - http://hg.mozilla.org/mozilla-central/rev/d2bd42931b03 - work

Therefore regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d2bd42931b03&tochange=c6e65b6259db

I've suspicious to Bug 613977 checkin
I can not set blocking2.0? flag, but IMHO it should block. Webmoney (http://en.wikipedia.org/wiki/Webmoney) is major online payment system and breaking this system sucks a lot.
blocking2.0: --- → ?
A different bug involving client certificates (623785) was mistakenly thought to be related to 613977 - but is instead a dup of 624075. Maybe this is too?

613977 has been removed from the tree as of c1b1fde638f9 (bug 623921)- so you ought to be able to check against a newer build. there aren't any known problems with it and it will be reintroduced later, so it would be good to know what you find.
I've tested latest tinderbox build 20110109 built from http://hg.mozilla.org/mozilla-central/rev/4a3866321a14 and problem still presents. Perhaps it's dupe of Bug 624075
Is there any chance to get try Linux build with http://hg.mozilla.org/mozilla-central/rev/d2856d5970b6 reverted to verify it?
Depends on: 624075
WFM in Mozilla/5.0 (X11; Linux i686; rv:2.0b10pre) Gecko/20110113 Firefox/4.0b10pre ID:20110113030355
Looks like it was fixed by backout of the patch that caused this regression as indicated in Bug 624075 comment 14
Status: NEW → RESOLVED
blocking2.0: ? → ---
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 624075
You need to log in before you can comment on or make changes to this bug.