In profile w/ saved Gmail password, Fennec repeatedly prompts me for Master Password when I type each character of "gmail" in AwesomeScreen

VERIFIED FIXED in Firefox 8

Status

Fennec Graveyard
General
VERIFIED FIXED
6 years ago
3 years ago

People

(Reporter: dholbert, Assigned: wesj)

Tracking

({verified-aurora})

Trunk
Firefox 8
verified-aurora

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
STEPS TO REPRODUCE:
 1. Save a password for gmail in Fennec, and login & view your mail.
 2. Install Master Password addon:
    https://addons.mozilla.org/en-US/mobile/addon/270907/
 3. Restart Fennec and add a Master Password.
 4. Restart Fennec again. (so that Master Password is locked)
 5. In AwesomeScreen, *slowly* type the word "gmail" (character by character)

ACTUAL RESULTS:
At some point while you're typing "gmail" (I think at the point where your gmail mailbox page appears in the dropdown list), Fennec darkens the AwesomeScreen (interrupting your URL-typing) and pops up a Master Password dialog *over the awesome screen*

EXPECTED RESULTS:
Awesomescreen shouldn't prompt me like that.

mfinkle says in IRC that this is due to a "badging" feature where we try to auto-load gmail in the background and show the unread mail count in the awesomescreen, if you have a saved gmail login.

However, this is inappropriate in the locked-Master-Password use-case, because it triggers annoying & unexpected master password prompts that interrupt the user's typing in the awesomescreen.

Reproduced with latest Fennec nightly on a Linux desktop as well as on an Android phone.
(Reporter)

Updated

6 years ago
Blocks: 592772
Matt, looks like something to fix in the next version of the master password extension!
(Reporter)

Comment 2

6 years ago
Now that bug 592772 has landed (adding Master Password support to Fennec), this has become a bug in stock Fennec. (rather than a bug in fennec-with-an-addon)

I verified that STR still reproduce this, in latest stock Fennec nightly.  (one addition: be sure to cancel any Master Password dialogs that appear).

In fact, I get prompted repeatedly -- once for each character of "gmail.com" that I type into the location bar.  (assuming I cancel each MP dialog)

I think we absolutely need to support the "I don't feel like typing my MP in right now, I just want to type in a URL and go there" use-case, and this bug makes that use-case super-annoying.
Component: Extension Compatibility → General
OS: Linux → All
QA Contact: extension-compatibility → general
Hardware: x86_64 → All
Summary: In profile w/ saved Gmail password & Master Password extension, Fennec prompts me for Master Password when I type "gmail" in AwesomeScreen → In profile w/ saved Gmail password & Master Password, Fennec prompts me for Master Password when I type "gmail" in AwesomeScreen
(Reporter)

Updated

6 years ago
Summary: In profile w/ saved Gmail password & Master Password, Fennec prompts me for Master Password when I type "gmail" in AwesomeScreen → In profile w/ saved Gmail password, Fennec repeatedly prompts me for Master Password when I type each character of "gmail" in AwesomeScreen
(Assignee)

Updated

6 years ago
Assignee: nobody → wjohnston
(Reporter)

Updated

6 years ago
tracking-fennec: --- → ?
status-firefox8: --- → affected
(Assignee)

Comment 3

6 years ago
Created attachment 554941 [details] [diff] [review]
Patch v1

This works for me, but the nsIPK11Token docs are sparse enough I'm not positive this is the right way to do it.
Attachment #554941 - Flags: review?(alexp)
Comment on attachment 554941 [details] [diff] [review]
Patch v1

I'm not an expert in the PSM stuff, but as far as I can tell, it looks fine, especially if it works for you as supposed.
Not sure though if you need a separate getter for nsIPK11TokenDB. Won't just a local variable be enough?
Attachment #554941 - Flags: review?(mark.finkle)
Attachment #554941 - Flags: review?(alexp)
Attachment #554941 - Flags: feedback+
Comment on attachment 554941 [details] [diff] [review]
Patch v1

caching the token DB is a good idea
Attachment #554941 - Flags: review?(mark.finkle) → review+
http://hg.mozilla.org/mozilla-central/rev/e588d3deca71
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 9
Comment on attachment 554941 [details] [diff] [review]
Patch v1

Requesting approval to land in Aurora for Firefox 8.  This is a low-risk mobile-only change that fixes a very annoying user-visible regression/bug in a new feature in Fennec 8 (Master Password).

[Alternately, we could disable Master Password in Firefox 8 and wait until 9 to ship it.]
Attachment #554941 - Flags: approval-mozilla-aurora?

Updated

6 years ago
Attachment #554941 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

6 years ago
tracking-firefox8: --- → +
https://hg.mozilla.org/releases/mozilla-aurora/rev/716ae806a90f
status-firefox8: affected → fixed
Target Milestone: Firefox 9 → Firefox 8
I've performed the steps from comment #0, and it's working fine on the latest Aurora build. I'll mark it as verified fixed.

--
Mozilla/5.0 (Android;Linux armv7l;rv:8.0a2)Gecko/20110908
Firefox/8.0a2 Fennec/8.0a2
Device: Samsung Galaxy S
OS: Android 2.2
Status: RESOLVED → VERIFIED
QA not tracking; fix has been sufficiently verified.
Whiteboard: [qa-]

Updated

6 years ago
Keywords: verified-aurora
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.