IAccessible::get_accChild broken for child indices

VERIFIED FIXED in mozilla2.0b10

Status

()

defect
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: surkov, Assigned: surkov)

Tracking

({access, regression})

unspecified
mozilla2.0b10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [hardblocker])

Attachments

(1 attachment)

Assignee

Comment 1

9 years ago
request a blocking as regression from betas.
blocking2.0: --- → ?
Assignee

Comment 2

9 years ago
Posted patch patchSplinter Review
Assignee: nobody → surkov.alexander
Status: NEW → ASSIGNED
Attachment #502746 - Flags: review?(bolterbugz)
Comment on attachment 502746 [details] [diff] [review]
patch

>+  // Gecko child indices are 0-based in contrast to indices used in MSAA.

Might as well be explicit:
// Gecko child indices are 0-based and MSAA child indices are 1-based.
Attachment #502746 - Flags: review?(bolterbugz) → review+
Thanks for jumping on this one Alexander. Approving blocking since this is major.
blocking2.0: ? → final+

Updated

9 years ago
Whiteboard: [hardblocker]
Assignee

Comment 5

9 years ago
landed on 2.0 - http://hg.mozilla.org/mozilla-central/rev/a659f574f159
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b10
Assignee

Comment 6

9 years ago
(In reply to comment #3)
> Comment on attachment 502746 [details] [diff] [review]
> patch
> 
> >+  // Gecko child indices are 0-based in contrast to indices used in MSAA.
> 
> Might as well be explicit:
> // Gecko child indices are 0-based and MSAA child indices are 1-based.

Forgot to change the comment, hope that's ok.
Verified fixed via Sylvain on the mailing list.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.