Custom keyboard shortcuts created in System Preferences are improperly respected (Both "command-q" and "shift-command-q" now quit Firefox, after new assignmet of "shift-command-q" to Quit Firefox)

RESOLVED DUPLICATE of bug 938303

Status

()

RESOLVED DUPLICATE of bug 938303
8 years ago
5 years ago

People

(Reporter: matthew.a.shapiro, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8) Gecko/20100101 Firefox/4.0b8
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8) Gecko/20100101 Firefox/4.0b8

In OS X you can use the Keyboard preference pane of System Preferences to create custom shortcuts for any menu item in any program. Additionally, you can create custom shortcuts for menu items that already have a shortcut built-in; according to Apple's HID guidelines, when a custom shortcut is created the existing built-in one is supposed to be disabled. Because of chronically pressing command-q instead of command-w when I want to close a tab, I have remapped "Quit Firefox" to be shift-command-q. I've done this with Chrome and Safari as well, and in those cases command-q no longer closes the browser. In Firefox, the menu now shows the new shortcut, but both shortcuts quit Firefox.

Reproducible: Always

Steps to Reproduce:
1. Open System Preferences - Keyboard
2. Under Shortcuts, create a new custom one for Firefox; menu = "Quit Firefox", shortcut = "shift-command-q".
3. Quit Firefox (if running) and re-open. New shortcut is shown next to "Quit Firefox".
Actual Results:  
Both "command-q" and "shift-command-q" now quit Firefox.

Expected Results:  
Only "shift-command-q" should remain active, per Apple's interface design guidelines.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429824
(In reply to Jo Hermans from comment #1)
> *** This bug has been marked as a duplicate of bug 429824 ***

This bug is for;
> Actual Results:  
> Both "command-q" and "shift-command-q" now quit Firefox.
Bug 429824 is for problem of "new short cut doesn't work".
How can this bug be dup of bug 429824?
Jo Hermans, how did you veryfy that this bug is actually dup of bug 429824?

Re-opening, with setting dependency to bug 938303 for ease of problem analysis and tracking.
Depends on: 938303
Summary: Custom keyboard shortcuts created in System Preferences are improperly respected → Custom keyboard shortcuts created in System Preferences are improperly respected (Both "command-q" and "shift-command-q" now quit Firefox, after new assignmet of "shift-command-q" to Quit Firefox)
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
Problem will be fixed by bug 938303. Duping to that bug.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago5 years ago
No longer depends on: 938303
Resolution: --- → DUPLICATE
Duplicate of bug: 938303
You need to log in before you can comment on or make changes to this bug.