If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

undo close tab does not restore page with frameset

RESOLVED FIXED in mozilla2.0

Status

()

Core
Document Navigation
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Stefan, Assigned: smaug)

Tracking

({regression})

Trunk
mozilla2.0
x86
All
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [softblocker], URL)

(Reporter)

Description

7 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b9pre) Gecko/20101229 Firefox/4.0b9pre

http://www.irfanview.net/ is not restored properly if close is undone.

Reproducible: Always

Steps to Reproduce:
1. open http://www.irfanview.net/
2. close tab
3. undo close tab
Actual Results:  
MF displays empty page, only the browser's title is set.

Expected Results:  
Display page-content as it was when close tab was executed.

Comment 1

7 years ago
Confirmed on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110111 Firefox/4.0b10pre ID:20110111030357

Regression window(cached houry):
Works:
http://hg.mozilla.org/mozilla-central/rev/7fb1bd5802f0
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100820
Minefield/4.0b5pre ID:20100820150311
Fails:
http://hg.mozilla.org/mozilla-central/rev/cbf6e0a17783
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b5pre) Gecko/20100820
Minefield/4.0b5pre ID:20100820190548
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7fb1bd5802f0&tochange=cbf6e0a17783

Suspected:
cbf6e0a17783    Olli Pettay — Bug 588643 - Crash in [@
nsDocShell::SetHistoryEntry ], r=bent/neil, a=blocking
Blocks: 588643
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Component: General → Document Navigation
Ever confirmed: true
Keywords: regression
OS: Linux → All
Product: Firefox → Core
QA Contact: general → docshell
Target Milestone: --- → mozilla2.0
Version: unspecified → Trunk
(Reporter)

Comment 2

7 years ago
A similar issue I have already reported in Bug 609396.

diff -r aafe919e786e docshell/shistory/src/nsSHEntry.cpp
--- a/docshell/shistory/src/nsSHEntry.cpp Sun Nov 07 13:59:51 2010 +0100
+++ b/docshell/shistory/src/nsSHEntry.cpp Sun Nov 07 14:40:01 2010 +0100
@@ -647,7 +647,7 @@
   // If aOffset is larger than Count(), we must first manually
   // set the capacity.
   if (aOffset > mChildren.Count()) {
-    mChildren.SetCount(aOffset);
+    // mChildren.SetCount(aOffset);
   }
   if (!mChildren.InsertObjectAt(aChild, aOffset)) {
     NS_WARNING("Adding a child failed!");

cures both of the issues.
Blocks: 609396
Olli, looks like a regression from your changes. Can you have a look?
Assignee: nobody → Olli.Pettay
blocking2.0: ? → final+
Whiteboard: [softblocker]

Comment 4

7 years ago
Also reproduced on mac 64 builds.

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b10pre) Gecko/20110117 Firefox/4.0b10pre
(Reporter)

Comment 5

7 years ago
Fixed with fix of Bug 632835 (http://hg.mozilla.org/mozilla-central/rev/6229fab0d2e6)
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Updated

7 years ago
Depends on: 632835
You need to log in before you can comment on or make changes to this bug.