Closed Bug 625 Opened 22 years ago Closed 21 years ago

floating image inteferes with painting (layer involved)

Categories

(Core :: Layout, defect, P2)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: buster, Assigned: karnaze)

References

()

Details

see the bottom of the url for the problem, or look at this minimized test case:

<HTML>
<BODY BACKGROUND="/images/curve_aqua.gif" BGCOLOR="#FFFFFF" TEXT="#000000"
LINK="#DD0000" VLINK="#999999" ALINK="#FF0000" ALT="wave">

<table width=640>
<tr>
<td width="468" colspan="2">
	<TABLE BORDER="0" BGCOLOR="#66cccc" WIDTH="468">
	<TR>
	<TD BGCOLOR="#66cccc" ALIGN="CENTER">A N N O U N C E M E N T S</TD>
	</TR>
	<TR>
	<TD ALIGN="CENTER" VALIGN="TOP">
		<TABLE CELLSPACING="0" WIDTH="468" BORDER="0" VALIGN="TOP">
		<TR>
		<TD VALIGN="TOP" WIDTH="68" BGCOLOR="#FFFFFF" ALIGN="LEFT">
			<IMG src="http://www.DEVELOPER.com/images/check.gif"
Align="left" Alt="Announcements" BORDER="0">
		</TD>
		<TD VALIGN="TOP" BGCOLOR="#FFFFFF" ALIGN="LEFT" WIDTH="400"
COLSPAN="4">
			<IMG src="http://www.DEVELOPER.com/images/redear.gif"
WIDTH="8" HEIGHT="8" BORDER="0">Dozens of new job openings at the <a
href="/jobs/">Job Bank</a>.<BR>
		</TD>
		</TR>
		</TABLE>

		<TABLE CELLSPACING="0" WIDTH="468" BORDER="0" VALIGN="TOP">
		<TR>
		<TD BGCOLOR="#66cccc" ALIGN="CENTER" WIDTH="234">
		</TD>
		<td width="0" bgcolor="#66cccc">
			<nowrap><img
src="http://www.DEVELOPER.com/images/rule.gif" HEIGHT="10" WIDTH="1">
		</td>
		<TD BGCOLOR="#66cccc" ALIGN="CENTER" WIDTH="234">
		</TD>
		</TR>
		<tr>
		<TD VALIGN="TOP" WIDTH="234" BGCOLOR="#FFFFFF">
		</TD>
		<td width="0" bgcolor="#66cccc"><nowrap><img
src="http://www.DEVELOPER.com/images/dotclear.gif" HEIGHT="1" WIDTH="1"></td>
		<TD VALIGN="TOP" WIDTH="234" BGCOLOR="#FFFFFF">
		</TD>
		</TR>
		</TABLE>
	</TD>
	</TR>
	</TABLE>
</td>
</tr>
</table>
</BODY></HTML>
Status: NEW → ASSIGNED
Component: Unknown → Layout
the primary bug is fixed, however, this page exhibits and overlaying problem
Assignee: kipp → rickg
Status: ASSIGNED → NEW
The parser is not handling ILAYER and LAYER properly. The following
simplification of the page (the page uses javascript to document.write this, by
the way) doesn't parse properly.

<HTML>
 <HEAD>
  <BASE HREF=http://www.developer.com>
 </HEAD>
 <BODY>
  <TABLE WIDTH=88 HEIGHT=160 CELLSPACING=0 CELLPADDING=0 BORDER=1>
   <TR>
    <TD>
     <A TARGET="new win"
HREF="http://msdn.microsoft.com/vstudio/headlines/ad/vsdev.htm">
      <ILAYER VISIBILITY=SHOW CLIP=\"0,0,88,76\" ID=lr0>
       <LAYER ID=lr1>
        <TABLE BORDER=0 CELLPADDING=0 CELLSPACING=0 WIDTH=88>
         <TR>
          <TD>
           <FONT SIZE=-1>
            <FONT FACE=ARIAL>
             <A target=new
HREF=http://msdn.microsoft.com/vstudio/headlines/ad/vsdev.htm>
              <FONT COLOR=BLACK>
               <IMG WIDTH=88 HEIGHT=300 SRC=/ticker/dev_ticker_static.gif
BORDER=0>
              </FONT>
             </A>
            </FONT>
           </FONT>
          </TD>
         </TR>
        </TABLE>
       </LAYER>
      </LAYER>
     </A>
     <BR>
     <IMG WIDTH=88 HEIGHT=88 SRC="/images/88x88alt.gif">
     <A TARGET="new win"
HREF="http://msdn.microsoft.com/vstudio/headlines/ad/vsdev.htm">
      <IMG BORDER=0 WIDTH=88 HEIGHT=88 SRC="/images/88x88alt.gif">
     </A>
    </TD>
   </TR>
  </TABLE>
 </BODY>
</HTML>
Status: NEW → ASSIGNED
Assignee: rickg → buster
Status: ASSIGNED → NEW
Steve -- this appears to be caused by a table cell with an image whose width and
height are set to 85%. If you eliminate the % specifiers on the image, then
developer.com works great. This was the basis for a bug I just wrote up and sent
to you.
Status: NEW → ASSIGNED
Setting all current Open/Normal to M4.
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser
changed misc bugs to M6
setting my table bugs to M9
Assignee: buster → karnaze
Status: ASSIGNED → NEW
Chris:  somehow, a couple of table bugs slipped through my filter.  reassigning
to you.
Assignee: karnaze → vidur
Summary: floating image inteferes with painting → floating image inteferes with painting (layer involved)
Target Milestone: M9 → M10
Using Kipp's example of 11/6, it appears that the parser is correct, but the
layout is still wrong. When I remove the layer tags, Gecko looks identical
to Nav4.6. I added "(layer involved)" to the summary.

Vidur, do you know what is going on. If tables need to change to make this work,
I hope you have some ideas.
Assignee: vidur → karnaze
Hmm...looks like the original site has changed - there are no longer any layers
and the layout looks reasonable except for the banner ad image that's offset to
the right (and in a table). Handing the bug back to Chris - there are no longer
any layers issues.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Fixed the "click here" banner placement with the latest checkin.
Status: RESOLVED → VERIFIED
Based on the original description, this problem is fixed in the Sept 13th build.
You need to log in before you can comment on or make changes to this bug.