support.mozilla.com does not redirect to localized version

RESOLVED DUPLICATE of bug 621389

Status

support.mozilla.org
General
--
major
RESOLVED DUPLICATE of bug 621389
7 years ago
6 years ago

People

(Reporter: atopal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
On prod the startpage at support.mozilla.com redirects to support.mozilla.com/en-US not to the actual locale of the user. It works on master though. This means that unless people find the locale switcher on the lower right, they are all getting the English KB.
What's your Accept-Language header? (Or about:config: intl.accept_languages?) Is this 100% reliable and always going to en-US? When I set the Accept-Language header to "fr, en-us; q=0.8; en; q=0.6" I go to support.mozilla.com/fr/home on prod.
Component: Knowledge Base Software → General
QA Contact: kb-software → general

Comment 2

7 years ago
In about:config the value for me is: it-it, it, en-us, en (default for Italian localized builds of Firefox) and I always go to 

http://support.mozilla.com/en-US/home
(Reporter)

Comment 3

7 years ago
I was using Safari, since I use an en-US Firefox, but the Safari Accept-Language starts with 'de', and yes, this is reproducable.
So it sounds like a duplicate of bug 621389. Is there anything different about this?
(Reporter)

Comment 5

7 years ago
I can't say for sure, but that bugs seems to be not reproducable (thread safety), this one is a redirct to en-US everytime I try.

Comment 6

6 years ago
I can't reproduce.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 621389
You need to log in before you can comment on or make changes to this bug.