Fennec crash when closing a tab

RESOLVED DUPLICATE of bug 623728

Status

RESOLVED DUPLICATE of bug 623728
8 years ago
8 years ago

People

(Reporter: vingtetun, Unassigned)

Tracking

Trunk
x86_64
Linux

Details

When closing a tab opened during tests fennec crash with:

    ###!!! ABORT: unknown union type: file PLayersParent.cpp, line 560
    mozilla::layers::PLayersParent::Write(mozilla::layers::SurfaceDescriptor const&, IPC::Message*) (/home/vivien/Devel/mozilla/fennec/build/ipc/ipdl/PLayersParent.cpp:564)
    mozilla::layers::PLayersParent::Write(mozilla::layers::ThebesBuffer const&, IPC::Message*) (/home/vivien/Devel/mozilla/fennec/build/ipc/ipdl/PLayersParent.cpp:1660)
    mozilla::layers::PLayersParent::Write(mozilla::layers::OpThebesBufferSwap const&, IPC::Message*) (/home/vivien/Devel/mozilla/fennec/build/ipc/ipdl/PLayersParent.cpp:1416)
    mozilla::layers::PLayersParent::Write(mozilla::layers::EditReply const&, IPC::Message*) (/home/vivien/Devel/mozilla/fennec/build/ipc/ipdl/PLayersParent.cpp:881)
    mozilla::layers::PLayersParent::Write(InfallibleTArray<mozilla::layers::EditReply> const&, IPC::Message*) (/home/vivien/Devel/mozilla/fennec/build/ipc/ipdl/PLayersParent.cpp:1851)
    mozilla::layers::PLayersParent::OnMessageReceived(IPC::Message const&, IPC::Message*&) (/home/vivien/Devel/mozilla/fennec/build/ipc/ipdl/PLayersParent.cpp:229)
    mozilla::dom::PContentParent::OnMessageReceived(IPC::Message const&, IPC::Message*&) (/home/vivien/Devel/mozilla/fennec/build/ipc/ipdl/PContentParent.cpp:1242)
    mozilla::ipc::SyncChannel::OnDispatchMessage(IPC::Message const&) (/home/vivien/Devel/mozilla/fennec/mozilla-central/ipc/glue/SyncChannel.cpp:169)
    mozilla::ipc::RPCChannel::OnMaybeDequeueOne() (/home/vivien/Devel/mozilla/fennec/mozilla-central/ipc/glue/RPCChannel.cpp:431)
    void DispatchToMethod<mozilla::ipc::RPCChannel, bool (mozilla::ipc::RPCChannel::*)()>(mozilla::ipc::RPCChannel*, bool (mozilla::ipc::RPCChannel::*)(), Tuple0 const&) (/home/vivien/Devel/mozilla/fennec/mozilla-central/ipc/chromium/src/base/tuple.h:384)
    RunnableMethod<mozilla::ipc::RPCChannel, bool (mozilla::ipc::RPCChannel::*)(), Tuple0>::Run() (/home/vivien/Devel/mozilla/fennec/mozilla-central/ipc/chromium/src/base/task.h:308)
    mozilla::ipc::RPCChannel::RefCountedTask::Run() (/home/vivien/Devel/mozilla/fennec/build/ipc/glue/../../dist/include/mozilla/ipc/RPCChannel.h:450)
    mozilla::ipc::RPCChannel::DequeueTask::Run() (/home/vivien/Devel/mozilla/fennec/build/ipc/glue/../../dist/include/mozilla/ipc/RPCChannel.h:475)
    MessageLoop::RunTask(Task*) (/home/vivien/Devel/mozilla/fennec/mozilla-central/ipc/chromium/src/base/message_loop.cc:344)
    MessageLoop::DeferOrRunPendingTask(MessageLoop::PendingTask const&) (/home/vivien/Devel/mozilla/fennec/mozilla-central/ipc/chromium/src/base/message_loop.cc:354)
    MessageLoop::DoWork() (/home/vivien/Devel/mozilla/fennec/mozilla-central/ipc/chromium/src/base/message_loop.cc:451)
    mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) (/home/vivien/Devel/mozilla/fennec/mozilla-central/ipc/glue/MessagePump.cpp:114)
    MessageLoop::RunInternal() (/home/vivien/Devel/mozilla/fennec/mozilla-central/ipc/chromium/src/base/message_loop.cc:220)
    MessageLoop::RunHandler() (/home/vivien/Devel/mozilla/fennec/mozilla-central/ipc/chromium/src/base/message_loop.cc:203)
    MessageLoop::Run() (/home/vivien/Devel/mozilla/fennec/mozilla-central/ipc/chromium/src/base/message_loop.cc:176)
    nsBaseAppShell::Run() (/home/vivien/Devel/mozilla/fennec/mozilla-central/widget/src/xpwidgets/nsBaseAppShell.cpp:198)
    nsAppStartup::Run() (/home/vivien/Devel/mozilla/fennec/mozilla-central/toolkit/components/startup/src/nsAppStartup.cpp:191)
    XRE_main (/home/vivien/Devel/mozilla/fennec/mozilla-central/toolkit/xre/nsAppRunner.cpp:3695)
    main (/home/vivien/Devel/mozilla/fennec/mozilla-central/mobile/app/nsBrowserApp.cpp:155)


Fennec does not crash if the <browser /> element is not removed from the DOM (if i removed http://mxr.mozilla.org/mobile-browser/source/chrome/content/browser.js#2627)

Steps to reproduce:
 * remove the // XXX bug (this bug number)
 * launch the test browser_formsZoom.js

I'm usually launching the test by:
cd _tests/testing/mochitest
python runtests.py --appname=../../../dist/bin/fennec --xre-path=../../../dist/bin --browser-chrome --autorun --test-path=mobile/chrome/browser_formsZoom.js


It crash evertyme for me.
That stack looks like one of the symptoms of bug 623728.  How old is your build?
(In reply to comment #1)
> That stack looks like one of the symptoms of bug 623728.  How old is your
> build?

from yesterda(In reply to comment #1)
> That stack looks like one of the symptoms of bug 623728.  How old is your
> build?

http://hg.mozilla.org/mozilla-central/rev/6d621e3fc42e

Looks like I've missed your patch from 2 hours, let me try to update and rebuild
It works now, thanks for pointing me to the bug!
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 623728
You need to log in before you can comment on or make changes to this bug.