Cannot rename a bookmark by using the "Del" keystroke

VERIFIED FIXED in mozilla2.0b10

Status

()

Core
Editor
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: Frédéric Buclin, Assigned: Away for a while)

Tracking

({regression})

Trunk
mozilla2.0b10
x86
Linux
regression
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [softblocker][fx4-fixed-bugday])

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
When I rename a bookmark in the personal bar from "foo bar" to "bar" by double-clicking "foo" and then pressing the Del keystroke, and then saving the change, the change is not effective. But if I click right before "bar", then hit the backspace keystroke several times to delete "foo", then it works.

Tested with 4.0 beta9. Aleksej can reproduce with yesterday's nightly.

Comment 1

7 years ago
Summary of comment 0: if the only action is to delete something from the bookmark's name using Del, it has no effect.

Comment 2

7 years ago
Regression window: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d1da1005b6d6&tochange=4f03895d544b
Keywords: regression
(Reporter)

Comment 3

7 years ago
Requesting blocking as it's a regression between beta 8 and beta 9.
blocking2.0: --- → ?
--> Core::Editor, strongly suspect Ehsan's patch for bug 527935. If that's the case, can someone please mention that over in that bug before we take it on branches and break those, too!
Component: Bookmarks & History → Editor
Product: Firefox → Core
QA Contact: bookmarks → editor
Assignee: nobody → ehsan
blocking2.0: ? → final+
Whiteboard: [softblocker]
Duplicate of this bug: 625655
(Assignee)

Comment 6

7 years ago
Can you reproduce this on trunk?  I couldn't on a mozilla-central nightly on Mac.
(Assignee)

Comment 7

7 years ago
I managed to reproduce this using the Cut command instead of pressing Del.
(Reporter)

Comment 8

7 years ago
(In reply to comment #7)
> I managed to reproduce this using the Cut command instead of pressing Del.

Looks like it's Cut on Mac and Del on Linux (I was testing on Linux).
(Assignee)

Comment 9

7 years ago
Yes, I've determined the cause.  The fix is easy, and I'll post a patch soon.
(Assignee)

Updated

7 years ago
Blocks: 527935
(Assignee)

Comment 10

7 years ago
Created attachment 504204 [details] [diff] [review]
Patch (v1)
Attachment #504204 - Flags: review?(roc)
(Assignee)

Updated

7 years ago
Whiteboard: [softblocker] → [softblocker][has patch][needs review roc]
Attachment #504204 - Flags: review?(roc) → review+
(Assignee)

Updated

7 years ago
Whiteboard: [softblocker][has patch][needs review roc] → [softblocker][needs landing]
(Assignee)

Comment 11

7 years ago
http://hg.mozilla.org/mozilla-central/rev/9698210ea3c6
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [softblocker][needs landing] → [softblocker]
Target Milestone: --- → mozilla2.0b10
(Assignee)

Updated

7 years ago
Attachment #504204 - Flags: approval1.9.2.15?
Attachment #504204 - Flags: approval1.9.1.18?
Comment on attachment 504204 [details] [diff] [review]
Patch (v1)

The regressing bug 527935 has not yet landed on old branches, and in that bug ehsan said none of the patches applied without merge work. Clearing the branch approval requests, but please re-request if this one was correct. (but a roll-up patch in bug 527935 is probably better.)
Attachment #504204 - Flags: approval1.9.2.15?
Attachment #504204 - Flags: approval1.9.1.18?
Verified fixed with Firefox 4b11build3.
Status: RESOLVED → VERIFIED
Whiteboard: [softblocker] → [softblocker][fx4-fixed-bugday]
You need to log in before you can comment on or make changes to this bug.