Last Comment Bug 625495 - Clear Adobe Flash Cookies (LSOs) when Clear Cookies is selected in the Privacy > Custom > Clear History When Firefox Closes > Settings... dialog
: Clear Adobe Flash Cookies (LSOs) when Clear Cookies is selected in the Privac...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Preferences (show other bugs)
: unspecified
: All All
: -- normal with 2 votes (vote)
: Firefox 4.0b10
Assigned To: dwitte@gmail.com
:
Mentors:
Depends on: 508167 625496
Blocks: 672107 565561
  Show dependency treegraph
 
Reported: 2011-01-13 14:32 PST by Mike Beltzner [:beltzner, not reading bugmail]
Modified: 2013-12-27 14:21 PST (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Mike Beltzner [:beltzner, not reading bugmail] 2011-01-13 14:32:15 PST
Bug 508167 will implement support for the NPAPI methods that Adobe Flash will support in Adobe Flash 10.2+, allowing us to tell that application to delete their version of cookies (LSOs) as well.

Previously we have seen a lot of evidence that users are surprised that Flash objects store data on their system and further that this data isn't cleared when browser cookies are cleared. It seems evident that to the user, cookies = cookies, and so the best way to match expectations would be to interpret cookie-clearing actions as meaning "web and flash cookies".

When "Custom" history options are selected in the "Privacy" prefpane, there is an option to "Clear History when Firefox Closes" that has "Settings...", one of which is cookies.

When that checkbox is selected, we should also use the new API from bug 508167 to clear Adobe Flash LSOs. Yes, this will clear all LSOs even those set by other browsers; that's acceptable, IMO.
Comment 1 dwitte@gmail.com 2011-02-01 21:04:05 PST
The implementation of this is identical to bug 625496, since they share the same backend. So we'll get this for free.
Comment 2 dwitte@gmail.com 2011-02-08 14:21:02 PST
Fixed by bug 625496.

Note You need to log in before you can comment on or make changes to this bug.