Make the ~ (home) recognized in the file:// protocol

RESOLVED DUPLICATE of bug 93141

Status

RESOLVED DUPLICATE of bug 93141
8 years ago
2 years ago

People

(Reporter: tarek, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
This won't work in Firefox:

file://~/file

Whereas this works:

file:///home/tarek/file

I think it would be nice to expand ~ when possible.

The way we expand it in Python is:

- under linux/mac os: looks for HOME in the env. If none, look into the password file to see if it's defined there.

- under Windows: looks for HOME, then for USERPROFILE then for HOMEDRIVE + HOMEPATH
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 93141
(Assignee)

Updated

2 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.