Last Comment Bug 625756 - [Atom] HTML elements are not recognized when they have an explicit prefix
: [Atom] HTML elements are not recognized when they have an explicit prefix
Status: RESOLVED DUPLICATE of bug 324333
:
Product: MailNews Core
Classification: Components
Component: Feed Reader (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-14 08:08 PST by Stéphane Bortzmeyer
Modified: 2013-09-29 13:17 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Stéphane Bortzmeyer 2011-01-14 08:08:13 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.16) Gecko/20101227 Iceweasel/3.5.16 (like Firefox/3.5.16)
Build Identifier: 3.0.11 Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.16) Gecko/20101227 Icedove/3.0.11

Because <html:p> is not recognized, everything ends in a paragraph.


Reproducible: Always

Steps to Reproduce:
1.Subscribe to http://www.bortzmeyer.org/feed-full.atom
2.Subscribe to http://www.rfc1149.net/tmp/atom.xml
3. 

The first feed uses content XHTML with explicit namespace prefixes, the second does not use prefixes. The first feed validates with every Atom validator.
Actual Results:  
The texts in the first case are in a single big paragraph.


Expected Results:  
It should recognize HTML elements even when they have an explicit prefix.

Here is a similar bug in Google Reader (now fixed): http://groups.google.com/group/google-reader-troubleshoot/browse_thread/thread/0b592d6496ed7607?pli=1

PS: I did not find a RSS or Syndication category in the Bugzilla for Thunderbird.
Comment 1 Stéphane Bortzmeyer 2011-01-14 08:10:47 PST
These articles talk about similar (but NOT identical) problems:

http://golem.ph.utexas.edu/~distler/blog/archives/000793.html

http://plasmasturm.org/log/376/
Comment 2 alta88 2013-09-29 13:17:41 PDT

*** This bug has been marked as a duplicate of bug 324333 ***

Note You need to log in before you can comment on or make changes to this bug.