Closed Bug 625771 Opened 9 years ago Closed 9 years ago

crash [@ xul.dll@0xb8334c ][@ nsTextControlFrame::SetSelectionInternal(nsIDOMNode*, int, nsIDOMNode*, int) ] while loading website

Categories

(Core :: Layout, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED FIXED

People

(Reporter: johnp, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b10pre) Gecko/20110114 Firefox/4.0b10pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b10pre) Gecko/20110114 Firefox/4.0b10pre

Firefox crashed first time visiting the URL with this signature:

crash[@ nsTextControlFrame::SetSelectionInternal(nsIDOMNode*, int, nsIDOMNode*, int) ] 
493ce450-12d9-4b51-9b74-bfc592110114

then, firefox was restarting w/o session restore it immediataly crashes like this:

crash [@ js::PropertyTable::search(int, bool) ] 
3dab6d0d-2347-4e6d-843e-0c4d72110114

and now i could reproduce crashing to times with this signature:

[@ xul.dll@0xb8334c ] 
97446b3d-1de0-40f3-b426-039c52110114
7fc1bc5c-4440-45c9-8576-94d002110114

Reproducible: Always

Steps to Reproduce:
1.Load the url
2.Wait some time (seems to be causes by translation)
Actual Results:  
Firefox crashes

Expected Results:  
Firefox doesn’t crash
With "restarting w/o session restore" I meant session got restored automatically (as far as I could see).
I can not reproduce on Win7.
Status: UNCONFIRMED → NEW
Component: General → Layout
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → layout
Summary: crash [@ xul.dll@0xb8334c ] while loading website → crash [@ xul.dll@0xb8334c ][@ nsTextControlFrame::SetSelectionInternal(nsIDOMNode*, int, nsIDOMNode*, int) ] while loading website
Version: unspecified → Trunk
Most likely a duplicate of bug 626014.  Please test a TryServer build
with that fix when they're ready (in a few hours):
http://ftp.mozilla.org/pub/mozilla.org/firefox/tryserver-builds/mpalmgren@mozilla.com-14b66a0e5da6
Depends on: 626014
Crash is fixed by the patch in bug 626014.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.