Closed Bug 625798 Opened 10 years ago Closed 10 years ago

Favicon problems when network connection error is displayed

Categories

(Toolkit :: Places, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 621274
Tracking Status
blocking2.0 --- final+

People

(Reporter: smaug, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [softblocker])

Load first http://www.mozilla.org and then http://www.mozillaaa.org/ in the
same tab.
The favicon of the first page is shown in the tab when the network error is
loaded.
Also, if you do back and then forward, the icon is now in the location bar too.
I can reproduce the second problem(back and then forward).

Regression window(cached m-c hourly):
Works:
http://hg.mozilla.org/mozilla-central/rev/e435c9812855
Mozilla/5.0 (X11; Linux i686; rv:2.0b9pre) Gecko/20101215 Firefox/4.0b9pre ID:20101215174043
Fails:
http://hg.mozilla.org/mozilla-central/rev/cd62a8afc52e
Mozilla/5.0 (X11; Linux i686; rv:2.0b9pre) Gecko/20101215 Firefox/4.0b9pre ID:20101215204205
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e435c9812855&tochange=cd62a8afc52e
I wonder if this should even block.
blocking2.0: --- → ?
Keywords: regression
I can reproduce the first one when I repeat the STR,
At first glance this is the same as bug 621274
In local build
Build from 6617dcb0d48a : fails
Build from 999385f355a3 : fails
Build from d65c65ef13a4 : works

So, this is regressen by Bug 599973 - Don't use steps for async favicons
Blocks: 599973
Component: Tabbed Browser → Places
Product: Firefox → Toolkit
QA Contact: tabbed.browser → places
Version: unspecified → Trunk
Same regression as bug 621274
Status: NEW → RESOLVED
blocking2.0: ? → final+
Closed: 10 years ago
Resolution: --- → DUPLICATE
Whiteboard: [softblocker]
Duplicate of bug: 621274
You need to log in before you can comment on or make changes to this bug.