Keyboard command enhancement: save lost scroll events (workaround for Bug 78414)

RESOLVED DUPLICATE of bug 483136

Status

()

Core
Document Navigation
--
enhancement
RESOLVED DUPLICATE of bug 483136
7 years ago
7 years ago

People

(Reporter: mr, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 (.NET CLR 3.5.30729)

[ Bug 78414 - "(PluginShortcuts) Application shortcut keys (keyboard commands such as f11, ctrl+t, ctrl+r) fail to operate when plug-in (flash, acrobat, quicktime) has focus" ]

Bug 78414 (Importance: major) was reported on 2001-05-01 and has not yet been solved - and it's not planned for Firefox 4 either. During the years its severity has grown along the ever broader use of flash and other plugins. Simply put, it makes Firefox a bad product. Since key handling inside/outside plugin objects is a delicate matter, people could discuss the theoretically best solution forever - instead of changing the behaviour to something better.

Here is a workaround for one of the most annoying results of the bug:

Problem:
When scrolling, it stops when cursor happens to be over a YouTube video.
Solution:
Never pass scroll events to a non-focused plugin object.

Please include this enhancement in Firefox 4.


Reproducible: Always

Steps to Reproduce:
1. Load a Youtube video page.
2. Give the plug-in focus by clicking Play.
3. Hover the plug-in and scroll.
Actual Results:  
No scrolling.

Expected Results:  
Scrolling as normal.
Component: Plug-ins → Document Navigation
QA Contact: plugins → docshell
Version: unspecified → Trunk

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 483136
You need to log in before you can comment on or make changes to this bug.