Error when posting into other frame initiated by INPUT with type image

VERIFIED INVALID

Status

()

Core
HTML: Form Submission
P3
normal
VERIFIED INVALID
18 years ago
18 years ago

People

(Reporter: Pavol Vaskovic, Assigned: rpotts (gone))

Tracking

({testcase})

Trunk
Other
Windows 98
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

3.40 KB, application/octet-stream
Details
(Reporter)

Description

18 years ago
When I try to submit a form with target specified, to point into another frame 
i get this error message in JavaScript Console and nothing is posted:
Error: focusedWindow.location has no properties
Source File: chrome://navigator/content/navigator.js
Line: 137 Column:0
I tryed to create a testcase and found this to be related with the input 
element being of type image. This bug can be related with bug 61385, becase 
this one had the same symptoms (posting two forms in two frames at a same, 
nothing happens but there is the error mentioned above in the JavaScript 
Console). Possible workaround are in the testcase.
(Reporter)

Comment 1

18 years ago
Created attachment 20492 [details]
TestCase for bug 62593
(Reporter)

Updated

18 years ago
Keywords: testcase

Comment 2

18 years ago
Browser, not engine. As with bug 61385, over to Security component - 
Assignee: rogerl → mstoltz
Component: Javascript Engine → Security: General
QA Contact: pschwartau → ckritzer

Comment 3

18 years ago
the focusedWindow error is caused by bug 56063, marking dependancy.
Depends on: 56063

Comment 4

18 years ago
Reporter can you still reproduce this with a latest nightly? the error in the
javascript console doesn't affect this bug...
(Reporter)

Comment 5

18 years ago
Yes, I can reproduce this with build 2001010204 on Win98.

No posting occurs until workarounds described in the testcase are applied 
EXCEPT that workaround 3. does no longer work (3. renaming image used in INPUT, 
so that it can not load) - has no affect now.

BTW I also noticed different browser behavior when testing posting offline 
(when there's no response from server): previous versions stopped "redrawing" 
the targeted frame; above mentioned build freezes. By "redrawing" I mean the 
possibility to select text with mouse.

Comment 6

18 years ago
Marking NEW as per comments.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This appears to be related to bug 61385, reassigning to rpotts, who owns that
one. Please reassign if I'm wrong.
Assignee: mstoltz → rpotts
Component: Security: General → Form Submission
(Reporter)

Comment 8

18 years ago
I no longer think this one is related with bug 61385 because that one has 
problem with termination of one "loading" with the second "loading". And that 
is not the case here. This one simply does not send the form! And is somehow 
related to the input being of type image. For expalmple input with type button 
works correct. So it has nothing to do with bug 61385 ! 
(Reporter)

Comment 9

18 years ago
I'm really sorry for the time wasted on this! This is NOT A BUG! I made more 
thorough research on this and found this: The input of type image surrounded by 
form element with no properties takes default action; it send the form 
with "get" method with the x y coordinates of the point clicked in the image. 
And does not perform the onClick action. That's why it did not change the 
second frame. And removing the empty form element is the solution for this. 
Than it behaves as desired (does the onClick). So please change the status of 
this bug accordindly. Once again sorry. 
(Reporter)

Comment 10

18 years ago
Not a bug. Reasons in the sprevious comment. 
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 11

18 years ago
No problem, thanks for investigating this yourself!
VERIFIED invalid.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.