Firefox's window freezes until Spaces or Expose are activated.

RESOLVED DUPLICATE of bug 603134

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 603134
9 years ago
8 years ago

People

(Reporter: g2k333, Unassigned)

Tracking

Trunk
x86
macOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

When a new window is opened by Firefox (Any window - browser's window, preferences window, source viewer etc.) the window will freeze and will not be (re)drawn until Expose or Spaces are activated. After that everything works fine until another window is opened.

When another window is moved over a frozen window, parts of it get redrawn but it remains in the frozen state. 

This bug is extremely annoying.

Reproducible: Always

Steps to Reproduce:
1. Open a new window
Actual Results:  
The window froze

Expected Results:  
It shouldn't have frozen

Firefox 4.0b9, Mac OS X Snow Leopard.
Reporter

Comment 1

9 years ago
Started happening since 4.0b8 or 4.0b7 - can't remember.

Comment 3

8 years ago
Same problem here with 4.0b10 on Mac OS 10.6.6.
More details:
- moving the window or resizing it, by just one pixel, is enough to have it redraw itself and unfreeze.
- any new window and dialog is affected, including the first window when Firefox launches
- this bug is absent in safe mode
Same problem here on:
MacBook 5,1
OS X 10.6.6

Started happening a while ago now, previously mentioned 4.0b8 or 4.0b7 could be correct as far as I remember.
It started happening after an update to Minefield, I removed minefield and my firefox profile trying to get rid of the problem, it still happens on a fresh nightly download with new profile.
The bug indeed doesn't happen when I start Minefield in safe mode.

I'm new to Bugzilla, but shouldn't this be a blocker?
pietervriesacker:
I don't know if you get the same problem and you are not the original reporter.

>The bug indeed doesn't happen when I start Minefield in safe mode.
There are 3 things that the safemode deactivates.
1) Please disable all installed extensions (Tools/addons/extensions on windows, should be similar on OS X) and restart Firefox.
2) if it still happens disabled the hardware acceleration in tools/options/advanced/general (edit/preferences/... afaik on OS X) and restart Firefox

Does this "fix" your problem ?
Please post the graphic section from about:support (enter as URL) if point 2 fixed your problem.

Comment 6

8 years ago
> 1) Please disable all installed extensions (Tools/addons/extensions on windows,
> should be similar on OS X) and restart Firefox.
Just like pietervriesacker, I already checked with a new profile (i.e. no extensions but "Feedback") before my first comment.

> 2) if it still happens disabled the hardware acceleration
This does fix the problem, at least in my case.

> Please post the graphic section from about:support
Adapter Description
0x21a00,0x20400

Vendor ID
0000

Device ID
0000

Adapter RAM

Adapter Drivers

Driver Version

Driver Date

Direct2D Enabled
false

DirectWrite Enabled
false

WebGL Renderer
ATI Technologies Inc. -- ATI Radeon HD 2600 PRO OpenGL Engine -- 2.1 ATI-1.6.26

GPU Accelerated Windows
0/1
marking new because there are 3 people with this issue and requesting blocking
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Component: General → Graphics
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → thebes
Version: unspecified → Trunk
(In reply to comment #5)
> pietervriesacker:
> I don't know if you get the same problem and you are not the original reporter.
I'm pretty sure I have the same problem as the original reporter.
When I launch recent builds of Minefield the window appears but then appears to freeze rendering (It shows a blank page, window title says "Minefield start page" and the tab title says "connecting…").
I can then force the window to redraw in specific areas by moving another window over these areas (revealing that Minefield did load the start page and thus the app doesn't hang, only the rendering). This doesn't permanently fix the issue. To really "fix" the issue so Minefield becomes usable I have to force it to completely redraw. For example by using exposé.

> 1) Please disable all installed extensions
I tried this and it didn't help. Then I tried to disable all plugins on top of that and it didn't help either.

> 2) if it still happens disabled the hardware acceleration
This fixed the problem, both with all extensions/plugins still disabled and after they're enabled again.

> Please post the graphic section from about:support
Adapter Description: 0x22600,0x20400
Vendor ID: 0000
Device ID: 0000
Adapter RAM:
Adapter Drivers:
Driver Version:
Driver Date:
Direct2D Enabled: false
DirectWrite Enabled:false
WebGL Renderer: NVIDIA Corporation -- NVIDIA GeForce 9400M OpenGL Engine -- 2.1 NVIDIA-1.6.26
GPU Accelerated Windows: 1/1 OpenGL

----
Since it seems to me like some  info about my GPU is missing from the about:support page I'll also include the info on my GPU from the system profiler application:

NVIDIA GeForce 9400M:
  Chipset Model:	NVIDIA GeForce 9400M
  Type:	GPU
  Bus:	PCI
  VRAM (Total):	256 MB
  Vendor:	NVIDIA (0x10de)
  Device ID:	0x0863
  Revision ID:	0x00b1
  ROM Revision:	3385
Status: NEW → RESOLVED
blocking2.0: ? → ---
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 603134
You need to log in before you can comment on or make changes to this bug.