Send Link does not work with Thunderbird 3.1.7

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: John Liebson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

With FF 4.0 Beta 8 & 9 (don't recall if this was seen with 7), when I click on "send Link," with TB as my default e-mail program, I always set an error message that TB is running but not responding and I must close window or restart computer.

If I close TB, then try Send Link, the TB composition module opens, but not the main TB program.

Error was seen with a new profile. Error does not appear if Firefox is run in Safe Mode. Error is not seen, or ever has been, with FF 3.x or earlier.

A few people have reported in the Builds forum on MozillaZine that Send Link works for them with FF 4.0 Betas.

Reproducible: Always

Steps to Reproduce:
1. See details, please.
2.
3.
Actual Results:  
The error message as delineated above.

Expected Results:  
A new TB outgoing e-mail message with the FF page link in that message.

Please feel free to change any part of this report if I've put in incorrect information such as the FF module: I'm not overly familiar with Bugzilla, etc.
(Reporter)

Comment 1

7 years ago
I created a new Thunderbird profile yesterday to do some further testing, and deselected the TB Profile Manager's "Don't ask on starting" option. With TB running, I returned to Firefox and tried to send a link; that action brought up the TB Profile Manager, which seems to explain why I keep getting the error message about TB running.

My guess, and it is nothing more than that, is that FF, instead of sending the link to TB's compose module, is instead sending a signal to start TB.
(Reporter)

Comment 2

7 years ago
I just received a message on MozillaZine about this; based on that message, I removed -no-remote from my Firefox 4.0 Beta 9 shortcut, opened FF, and successfully used Send Link.

Why this worked in shortcuts for versions of Firefox before 4.0 which I was testing, where those shortcuts included -no-remote and where Send Link worked, I have no idea, nor does it now matter.

Thus, I changing this report to Resolve/Works for Me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.